Can't see my Devialet Expert 200 on my network

While I can connect my MacBook Pro directly to my Expert, Roon does not see it on the network when I want to connect via WiFi

In order to help you, can you please how you are connecting your MacBook Pro to the Devialet: USB or UTP? Are you using Devialet AIR? Is the MacBook running Roon Core? Note that the Devialet cannot function as a Roon Endpoint.

Only way to talk to a Devialet expert series via networking is by using their proprietary AIR driver on a computer.

1 Like

Directly only as per Dr T’s advice above.

Indirectly by attaching your networked computer (or another RoonReady NAA) via USB/toslink etc.

Thanks for all your responses - to cover questions asked I have MacBook Pro with Devialet AIR installed. When I use TITAL Web Player I can connect to Expert through Devialet AIR, however when I use Roon I can’t - when I check the settings (Audio setup) I can’t see Devialet AIR listed but do see my Apple TV listed. Hope this makes sense?

When I used it briefly (AIR has never been stable for me even the latest beta) it showed up OK in the Roon Audio Outputs. Is it definitely running? I cant think of many other reasons why it wouldn’t show up, sorry. Perhaps a current AIR user can help.

Make sure that your AIR program is running in the background - otherwise it will not appear as an option under Roon. I suddenly lost AIR so I re-installed the AIR program (make sure you uninstall before re-installing) - however I realised that the AIR program was not running. Btw I use the Ethernet protocol over Wifi. Sometimes the AIR program shuts down during a re-boot. You will also need to configure your settings for AIR in Roon.

Thanks Rash - I had reinstalled Devialet AIR with no success - however after reading your post
I did a clean uninstall and reinstalled again and its working, so thanks.

That did happen to me once on an automatic software install on the operating system - Devialet AIR did not work so I did what you did and it worked again. I am glad it’s working for you again - it’s one of those annoying and irritating moments! - can do relate.

Looks like you’ve got things sorted, but just thought I would mention that you have to look at Roon as 2 different ways for connecting an Expert:

  1. Using Air, it will show up as an option under your Audio Zones
  2. Using connection direct from a computer (in my case a Mac Mini), where the Roon Core/Server is loaded, i.e. Roon sees the output as the option on the Mac Mini, and you then set the Expert for that particular input

Not at home at present so can’t show you any screenshot examples, but just thought I would mention you have 2 options for connecting to an Expert within Roon, 1. direct via Air, or 2. direct connection from Core computer.


Tanks John, I usually connect directly via USB but wanted to have the option to move my MacBook Pro further away from the Expert, hence the need for AIR, but yes it does show in the Audio section for devices connected to my Mac.

why dont you try our new native AIR support?


Thanks Danny and have - its great!!!