Can't set up network storage using Airport Extreme

Hi everyone,

I successfully built a fanless NUC running ROCK. Everything is fine if I use an internal or an USB disk for storage.

But I can’t get any access to a Wifi Airport Express hotspot with my storage disk connected to it.

No Wifi problems between the NUC and the Airport. In Roon Set up/storage, I use a path like smb:// disk/my music folder, where the IP address is the Airport one.
The credentials are set to “account” in the Airport set up, I type the name and the corresponding password for credentials in Roon but I get the same error message from Roon with “unauthorized access” to the shared folder.

I can see my disk with my Mac and I can log to it with the same credentials that are correct…

Any Idea ? Thanks !

Roon does not support AFP. Does the Airport Extreme support SMB for attached storage?


1 Like

Hi @Demetrios ---- Thank you for the post and the feedback. Bot are appreciated!

I wanted to touch base and see if any progress has been made here with the Airport extreme based on the feedback provided in Andrew’s post above? Please let me know and if further assistance is required I will be glad to lend a hand.


Thanks for your answers.
Yes the Airport Extreme supports SMB for attached storage : I used it with my former setup (Mac Mini running Roon Core, connected to an Airport Extreme via Wifi ; my HD storage was connected to the Airport in USB).

Today my storage is exactly the same HD connected in USB to the same Airport Express. My NUC running Roon Rock (Linux) can’t access it via Roon Remote on my Mac Mini. The problem looks like a credential issue (“unauthorized access”). Is it linked to Linux under Rock ?

Hi @Demetrios ---- Thank you for the follow up and confirming that information for us, very appreciated!

Moving forward, while I do not have access to an Airport Express to confirm how this type of setup can/should be configured under Linux I did do some searching around via Google to see how other Linux users set this up. I came across the following on an Ubuntu forum where a user was reporting a similar behavior.

They were able to access the drive mounted to the Airport Express via a MAC and Windows machine but not
from their Ubuntu based computer. The suggestion that was made to the user by a fellow Ubuntu + Airport Express user was the following:

“I’m fairly sure it has something to do with permissions. For me, the solution was to open AirPort Utility on my Mac, go to Disks->File Sharing, and set “AirPort Disks Guest Access” to “Read and write”. Once I did that, the drives connected to my AirPort Extreme showed up in the Network browser from Ubuntu.”


Hello Eric,

Thanks for your answer. I tried what you proposed without any success. Things were OK with Roon Core, I can’t find what’s wrong with ROCK. The Airport and the disk are the same, except the format in FAT 32.
I can see this disk attached to my Airport hotspot both with a windows PC or a Mac using the credentials I declare in the Airport utility, but not with Rock…

Hi @Demetrios — Thank you for the follow up and giving the proposed test a shot. The feedback is appreciated!

Continuing forward, may I very kindly ask you for the following:

  1. Please provide a screenshot displaying how you are trying to add the HD in Roon. I want to see all the credentials you are entering along with the mentioned error message.

  2. Please verify what the drive is formatted to.

  3. If you mount the drive directly to the NUC is it picked up by ROCK?


Hello Eric,

Here are a few screenshots : Disk sharing using account credentials in the Airport utility (in French, because I’m !):

Another one showing a network connection with my Mac, without any problem:


And the last one with Rock error message:

My disk “MUSIQUE” is formatted in FAT 32.
Thanks for helping.

I forgot : yes the same disk is directly picked up by Rock when connected in USB.

Hi @Demetrios ---- Thank you for touching base with me and providing the requested feedback. My sincerest apologies for slow response on my end.

Moving forward, I have been unable to get my hands on the gear necessary to test this configurations but one of our very helpful moderators after seeing this thread took it upon himself to test this configuration. He mentioned that he is seeing the same error you are reporting.

Based on the above there may not be much we can do here to get this configuration working with Roon because this behavior is more than likely occurring due to the SMB implementation being used on the AEX.


Thanks for answering. I still wonder why this is not the case with Roon Core running on a computer, where The Airport is well recognized by Roon…


I have same problem 2 years later it seems. I use AirPort Extreme 7.9.1. Mac OS Catalina . tried smb:// media/passport music/roon…
Roon adds for two minutes then says unexpected error occurred .

the above description of change disk access to read/write is not available to me on airport utility. Curiously, music folders on Mac have read/write access, but my backup media doesn’t.

I have an app called musicstreamer that has never had a problem connecting to AirPort Extreme backup media (in advanced settings on this app: smb version is auto vs. v1 or v2.-don’t know what that means…)

thanks, if anyone is out there.