Can't set volume for DigiOne

Core Machine (Operating system/System info/Roon build number)

Dell Latitude E6430
Windows 7 Enterprise
64bit OS with i7-3740QM CPU, 6GB RAM

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Router by Ethernet to tp-link Deco M5 unit A
Then wifi to tp-link Deco M5 unit B
Then back to Ethernet connection to Allo DigiOne Player

I could make this Ethernet the whole way but that doesn’t seem to be the issue.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

From DigiOne Player by coaxial cable to Denon DA-300USB D/A converter
Directly to Spectron Musician III (no preamp, so using variable volume control)

Description Of Issue


I am unable to set the volume level to anything other than zero. I have tried restarting everything, and disabling and reenabling the device.

Hi @Pat_Orchard,

Is there any change in behavior if you plug in the Allo DigiOne directly to the router? What kind of OS do you have installed on your DigiOne, is it using DietPi?

If i remember correctly based on my raspberry setup with a digione there are several ways of calling the soundcard - digione from within the raspberry os . I think if you setup the digione directly you could not use the volume (which is what you normally want of you can control the volume after the spdif transport) there are other options of calling the digione through the alsa layer, and then volume control should be possible.
I should hook up my old raspberry to check what the difference was… But if i remember correctly it was in specifying a different soundcard (still digione, but through alsa and not direct) in the raspi settings

Running Roopieee XL here

And I get the options here.

i’m using Dietpi, which also defaults on device volume, but i too can change the settings in device setup

Hi all,

Thanks for the replies. After reading them all, it seemed that the solution was to install Riopieee XL. I downloaded 20190922-ropieeexl-ose_rpi234-stable.bin. I also downloaded Etcher. I used that to flash the download onto the microSD card (using my Surface Pro 4). I then put the microSD card into the DigiOne Signature and booted it. The lights are green, but the network is not seeing the DigiOne.

Did I do something wrong?


Hi @Pat_Orchard,

Are you able to see the RopieeeXL in your router DHCP list? If you navigate to the RopieeeXL WebUI (http://ropieeexl.local/), does anything appear? Also, the RopieeeXL Getting Started Guide may provide some additional info.

Getting there. I was able to see the RopieeeXL. I set it up, etc. I now have what seems to be volume control with the RopieeeXL but still no sound. No change to the DigiOne setup. Still fixed at zero.

I’ve done this myself,
Try restarting everything.
Is the dac set to coax?
Is the coax plugged in?
Try reversing the coax cable.

I restarted everything.
I confirmed the dac is set to coax.
I confirmed the coax is plugged in.
I reversed the coax cable.
I tried a different coax cable.
I uninstalled and reinstalled Roon control and server.

Nothing. No sound. Nadda. I’m almost ready to give up. Does anybody have any more ideas on what I’m doing wrong?

Hi @Pat_Orchard,

Is the behavior the same if you select both the “Allo” and the “Main” zone prior to starting playback? Under your config screen for Airplay, do you see any other options under “Audio Output” other than “HAT”?

According to page 27 of the Ropieee Guide for Beginners, it looks like the Zone name in Roon must match the Ropieee Web Settings name, can you check this? Also tagging @spockfish in case he has other thoughts.

HI @Pat_Orchard,

Have you tried setting the volume to digital volume control? This means Roon will take care of it.

I’m also slightly confused with the screen shots… so to be clear: you only want to play audio via the Digione yes? And it does actually play (as in: the progress bar moves along) but you don’t hear anything?


  • How do I set the volume to digital volume control? That is what I want.
  • Yes, I only want to play audio via the DigiOne. And yes, it does actually play but I don’t hear anything.


  • How should I select both? Should I group them?
  • The other settings under Audio Output are AUTO, USB and OFF.

Here is where I’m at on all my settings:

(I’ve tried volume control enabled as well.)


(I’ve tried multiple combinations of settings on these.)

I’m still confused what you’re trying to do with Shairport (Airplay), especially in relationship with the Digione.

You can’t select them both. Furthermore the screenshot shows ‘nothing playing’ on the Allo zone.

I was trying to follow advice from mdelrossi by using RopieeXL. What I want to do is use Roon to control volume. The DigiOne shouldn’t be involved in changing volume. I can’t seem to figure out how to do that.

Ok. But in the basics it’s simple:

You want to play audio, via Roon/RAAT, on the Allo Digione and control the volume, right?

In that case don’t use XL, there is no need for that. Forget about the airplay stuff, it only complicates matters. So only focus on the Allo zone. So please set it to digital volume control (which it ain’t in the screenshots above), play some audio over it (which is not happening in the screenshots above) and tell us what’s happening.


OK. When I do that, the volume is set to 0 and I can’t change it.

(It doesn’t matter what I set the DSD Playback Strategy to, I still can’t change the volume from 0).

The bar doesn’t show progress through the song.

The zone shows it playing.
(the bar at the bottom is moving)

The volume range is shown from -80 to 0.

ok. And you don’t have sound?

Have you tried ‘fixed volume’? Be careful with the volume in this case, but the question is: have you ever heard any output from the Digione?

Not sure you should be altering the spdif output volume , surely the amp is for this stage.

Yes, I’ve tried fixed volume. I haven’t ever heard any output from the DigiOne. I have previously used my DAC/amp combination with Roon using USB into the DAC. That works fine. I’m trying to improve sound and performance with the DigiOne, but getting nothing at all out.