Can't setup ARC (yet another one)

Roon Core Machine

Running Core on a QNAP NAS TVS-473 . The Core has been updated to 2.0

Networking Gear & Setup Details

The NAS is connect to the Huawei HG255 Gateway via ethernet. UpnP is enabled on the Huawei.
The error message I get is:
{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xx.xxx.96.37”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:“Did not find UPnP service with WANIPConnection on network”}
}

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Hey @Cemil,

Thank you for your patience while we’ve diligently worked to reach every request for support with port forwarding. The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Thank you very much for your feedback Benjamin.

My modem/router is a Huawei Home gateway HG255s. UPnP is enabled on it. I have also set up a port forwarding on it (hopefully Ive done it right).

The core is running on a QNAP NAS with fixed IP address (port forwarding was done accordingly). However, between the core and the modem/router sits an HP Procurve 1800-24G Switch. I’m wondering if that could be blocking it.

Got it working !!

After spending all morning resetting every switch in the house (I have a couple of clever HP ones), I figured that my IP address was not static. A quick call to the service provider (and another $2/month) fixed that. Lo’ and behold, Roon configured it and I tried ARC with my phone and it worked immediately.

Thanks for the help.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.