Can't setup Roon Arc connection from Roon Core

Roon Core Machine

Dell XPS 13 9300 i5 2020 16 gig ram

Networking Gear & Setup Details

No idea. I’ll have to look it up.

Connected Audio Devices

Laptop and Iphone.

Number of Tracks in Library

8000 tracks

Description of Issue

I want to just run the Roon Arc locally over wifi in my room. I have the Roon Core running on my Laptop and I downloaded the Roon Arc for my Iphone 11. It worked for a day partially and then it disconnected completely. Here is the error I got. Is it possible to do this over wifi locally? I don’t really care if I can access Roon Core outside the local network.

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“96.aaa.bbb.ccc”,“router_external_ip”:“1xx.xxx.x.xxx”},
“status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.68.1”,“found_upnp”:true}
}

Doesn’t help with your ARC issue, but if you’re connecting via WiFi wouldn’t the Roon Remote App (it has way more functionality) be a better option for you?

This is essential to be able to offer any help, but looking at the error message it seems there more than one NAT in your network chain. However, I’m not able to explain why it worked previously.

You could try rebooted all your network equipment followed by the laptop that’s running the Roon Core.

Hi @Hiren_Patel,

The diagnostic message you’ve displayed shows that the Roon Core is unable to reach your mobile device using ARC due to multiple layers of network address translation, either in your local network or at the level of your internet service provider.

Note that this message is irrelevant if your phone is connected to the same WiFi network as your Core. You don’t need port forwarding at all on your local network; ARC will function just like Roon Remote on your home network, albeit but with fewer features.

You likely encountered this error because your phone defaulted to a 4G or 5G connection, temporarily dropping the WiFi connection. If you encounter issues with connectivity in ARC again, verify that your phone hasn’t disconnected from WiFi. Also double check that you don’t have multiple subnets in your home WiFi setup; please see our Networking Best Practices here: https://help.roonlabs.com/portal/en/kb/articles/networking-best-practices

If you are interested in working with tech support to resolve the issue with port forwarding to use ARC outside the home, let us know. Otherwise, you can ignore any port forwarding errors in Roon → Settings → ARC so long as you’re just using ARC (instead of Roon Remote) at home.

We’ll be watching for your response.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.