Cant start Roon on new Machine

Have been running Roon on Windows 7 on a laptop which couldn’t support OpenGL 3.0 but still worked i5 4 GB RAM.

Have bought a new machine i7 quad core DELL optiplex 9020 with 16GB RAM, 256GB SSD, 1 TB hard drive and AMD Radeon HD8570 1GB Graphics card. Windows 10.

Roon won’t start. I get the message: the video drivers on this system do not support OPENGL 3.0 This may be fixable by upgrading your drivers or upgrading your video card. GL_ARB_framebuffer_object is missing.

I have updated the drivers but I still can’t progress beyond this message when I try starting Roon. I have tried compatibility testing and still get the same message.

Do I need a new graphics card? If so, what type and size?

Re-install Roon from scratch and try again.

Updated through Windows? If so, I would suggest downloading the drivers directly from AMD and installing those. Also, what is the size of the screen you are using. I’m betting the scaling of windows is causing your desktop to be lower than the needed vertical pixels. Try lowering the windows scale and see if that helps as well.