Can't stream Tidal MQA

Core Machine (Operating system/System info/Roon build number)

QNAP TS651 roon server 1.6 (build 416) stable
Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

QNAP TS651 with USB cable directly to DAC (Matrix Audio X-Sabre Pro MQA), qnap nas on ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Matrix Audio X-Sabre Pro MQA DAC on USB connection to NAS

Description Of Issue

I am running my Roon server on an external SSD, connected to a QNAP TS651 nas, which is connected to my network with ethernet cables. I have a USB cable connected between the QNAP nas and my DAC which is capable of MQA unfolding (Matrix Audio X-Sabre Pro MQA).

I can play mp3 and FLAC music from both the files i already have on my nas as well as streamed through my Tidal account, however, the moment i try to play an MQA file, playback does not even happen, and the phone roon app drops the DAC, and immediately asks to “select an audio zone”.

I can play MQA files from the Roon app through my phone (Samsung S10) which unfolds the MQA correctly.

If i use my laptop and connect it directly to the DAC, and play off Roon, it can unfold and play MQA files without issue.

Could the issue be with Roon and my DAC not cooperating?

Post the settings of how you have the dac set up in roon.

Actually apologies. I can’t get full mqa on my s10 via the roon app. Please refer to this screenshot. I can, however, get bit perfect lossless with mqa through UAPP.

First pic is roon app on S10 phone

Second pic is UAPP on S10 phone

here are the screenshots for my DAC settings. I dont think i changed anything from the default.

even if i change MQA capabilities to “no MQA support” and disable MQA core decoder, the moment i try to play an MQA file, Roon will drop the DAC. It is not even able to play a partially unfolded portion/ FLAC portion.

Try changing the input depth to 24 bit.
The sabre specs as below say it is currently limited

thanks very much for trying to help.

i’ve changed the settings and i can now get it to at least play the song. i have to set the “max bits per sample” to 16. if i set it to 24 or 32, Roon will just not play the song and drop the dac.

if i set it to 16, this is what i get on playback:

if i connect the DAC directly to my laptop, i can playback MQA files without issue.

the DAC shows “MQA” which means it is fully unfolding the file properly.

and on Roon, i get this:

i’m guessing then, its some issue between the QNAP nas and my DAC?

It looks like it, I would contact the manufacturer about their Linux support. Is the NAS on the latest software?

Try the fixed position on the volume control

I think I’ve pretty much given up on this.

If I turn off the dac, the roon server/core no longer sees the dac anymore. Even if I plug/unplug the USB from the qnap. To see the dac again, I have to restart/reinstall the roon server.

Have decided to order a small htpc and hook up the dac directly to the htpc rather than to the nas.

Thanks to all who tried to help!

Hi @Roasty,

Can you confirm that you are using the newest firmware on the X-Sabre Pro? What happens if you try to host the Roon Core on your laptop and use the QNAP just as an endpoint instead of a Core, does the same issue occur?


Yep the matrix dac is on the latest firmware.

I have just tried your suggestion.
Core on laptop.
Dac connected to qnap nas.
It can only play music if “max bits per sample” is set at 16 and “max sample rate” is set at “up to 768khz”. The output for MQA is “high quality” green light on Roon, and the dac display does not show MQA.
If u use any other setting, the music will play for a split second with a purple light on Roon, and then music will suddenly stop and Roon will drop the DAC.

Hi @Roasty,

Thanks for giving that a try. Since the issue appears to be related to which output device is in use, I would reach out to Matrix Audio to see if they can comment on their Linux compatibility. It appears though that it is not fully compatible from what you have mentioned, so the Windows bridge may be your best bet in the interim.

1 Like

@noris thanks. I’ve emailed matrix audio to see what they say.


Hi, solved? I have the same problem with few dacs connected to Qnap: SMSL M400&SU9, Rotel RA1572 mkii.

„…try to play an MQA file, playback does not even happen, and the phone roon app drops the DAC, and immediately asks to “select an audio zone”

hey sorry, the matrix has been sold a while back. in any case, I never got the issue solved with running the dac off the nas.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.