Can't Update BIOS on NUC5i3RYH

I have a NUC5i3RYH that I am trying to convert to a ROCK (currently has Volumio installed on it). I cannot get the NUC to recognize the USB drive containing the .BIO file. When I boot and select F7 the USB drive is not listed, same if I try the BIOS recovery method. No idea where to go from here.

Edit: USB drive is FAT32 format; current BIOS of NUC is 0130.

Problem solved!

Hello @Robert_Daines,

Thanks for contacting support and glad to hear that the issue is resolved! Just for our records and for anyone else that may happen to experience the same issue, would you be able to let us know what the root cause was and how you managed to resolve it? IS the system working as expected after you updated the BIOS? Please let us know when possible.



Thank you for your response. I finally did get my NUC-based ROCK set up and running. The USB stick issue was solved by using a different USB stick. The NUC just would not recognize that particular USB stick despite the fact that my iMac and my Linux laptop had no issues with it. Totally irrational but that was the issue. Luckily I had another USB stick on hand to try.

The next problem that I encountered was after ROCK was installed on the NUC and booted for the first time. I was unable to get a valid IP address with only the IP address being reported. This was eventually solved by going into the BIOS setup menu and turning off the LAN, saving & rebooting, and then turning it back on again. When the NUC rebooted it was assigned a real IP address. Needless to say that neither of these issues had anything to do with the ROCK installation instructions but they did slow down the process considerably. Possibly someone with more experience would have recognized and solved the issues more quickly.

A final problem that I encountered was, however, due to an issue with the ROCK installation instructions. The version of ROCK that is flashed onto the USB stick for installation is not the current version. If you have already been using Roon, the instructions say to not log in but click on Restore from Backup. Unfortunately, the version of ROCK that was just installed does not allow restoration of backups. You must first log in and perform two successive updates in order to get the current ROCK version. At this point you can log out and then restore your database from a backup (meanwhile Roon has been chugging away creating a whole new database). This needs to be fixed. Either modify the installation instructions or provide a more current version of ROCK to be flashed to the USB stick. This is a known problem since I found the solution by searching the Roon Community site. Other than this, the installation instructions are very good.

Hope this helps.

Hello @Robert_Daines,

Thank you for your reply, I greatly appreciate the detail of your remarks and I’m confident that it will help others who experience the same issue as you getting up and running! I have forwarded your comments to the QA team who will be taking a closer look at the online ROCK version and documentation, thanks for pointing that out.

Since it seems that you have resolved the issue, I will be marking this thread as [Solved] but if you run into any other issues after the BIOS update, feel free to let me know via PM to reopen this thread or start a new one.

Thanks again and hope you have a great day!
– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.