Can't update Core to 2.0

Roon Core Machine

Mac mini late 2014
10.15.7
see attached screenshot

Networking Gear & Setup Details

Comcast router/ethernet/wifi

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I cannot update to 2.0 on my late 2014 Mac Mini running 10.15. I see a window that asks me to choose my Core and that it requires an update. So I select connect and get a second window that tells me the Mac mini is running 1.8 and is up to date. No further action is possible from this window. What do I do? I see no way to complete the update to the Core machine. Help!

Rob

Screen Shot 2022-09-25 at 10.33.15 AM

2 posts were split to a new topic: Provide help with a connection issue

I have also tried to access the core from a second laptop running Roon that hasn’t been updated to 2.0.

Again, no apparent pathway to update the Mac-mini to 2.0.

Any suggestions on how to fix this?

Thanks,

Rob

@Rob_Stone, I have cleaned up the thread for you.

To confirm, are you still experiencing this problem?

Yes, I am still experiencing the problems described in my post.
Rob

Okay, to recap, your core is on the Min (1.8), and the MacBook (2.0) is for control.

You can’t upgrade the core because it is incompatible with your controller, but it does meet the minimum requirement (macOS 10.5.)

To resolve this you need a controller on 1.8. Do you have a mobile device with 1.8?

How do I determine that my iOS controller is 1.8? I have tried to access the core via my iPad, but it does not permit an upgrade to 2.0. It says it’s updating but it just goes in the loop.
Rob

Go to Settings > About.

I am not able to locate the version number of Roon on my phone in Settings>About. Please explain how I do this.

On the iOS device, open Roon Remote, click on the hamburger icon (☰), and scroll right-to-left when it says, “General Storage Services…” At the end, you’ll see About. Click on this, and note details for Remote.

I cannot access that menu, because when the app opens, I see a window that says choose your Roon Core…so the hamburger is not accessible. What do I do now?

I have just determined that my phone is running 1.8. I tried to update the core from the phone, by doing the requested login, but it failed to update the core. It is in the same loop as before. This appears to be very buggy and unstable. Literally, the screen was jumping and flashing on my phone as it attempted and failed the update.

Just out of curiosity: try to reboot both, your MAC mini and your iPhone.

Can anyone help me with this? Roon has been disabled because of this update. Thanks in advance to anyone that can assist in getting Roon running again.
Rob

I did reboot both and it did not resolve the issue.

Roon is stil not working. And no help appears to be available to assist me in fixing this. I will attempt to uninstall 2.0 on my laptop and revert back to 1.8 and get running again. If you are considering “upgrading” to 2.0 proceed with caution. This update does not appear ready for release to me.

Hi @Rob_Stone.

I’m sorry you’re having issues and apologize for your frustrations. 2.0 is working for most but for a few, networking and legacy hardware has presented challenges.

Here’s what I prescribe.

  1. Update your MacOS.

  2. Download Roon 2.0 directly from our download server. It’s clear the automatic updates aren’t working for you and this will bypass it. Here’s that direct link.

Let me know how things go please!

Wes

Thanks for your reply. Did not see this until today. Frankly I gave up on 2.0. Could not get the server up to 2.0. So, I downgraded to Legacy 1.8 on my remote devices on both MacOS and iOS. I updated MacOS before I attempted to update to 2.0. Didn’t work. Roon updates previously have been seamless. 2.0 didn’t work and blocked access to Roon. Then, I had to figure out how to retreat to “Legacy 1.8”. None of this was foretold by Roon, nor is the documentation for installing 1.8 clear. This is what I see now.

My question is; if I “Click” to relaunch will it update to the new versions (Server and Remote) of 1.8 or will I be updated to 2.0, (which I am not interested in at this time)?

Thanks for your assistance.
Rob

Hi Ben,

Well, I am not Ira, although he responded to my thread. Nonetheless, I was still waiting for a response from tech support to address my issue. I am Rob Stone and hopefully you can find my account and assist me. Hope to hear from you soon.

Rob Stone

@Rob_Stone, this is the only thread @ira_kaufman, has posted in recent months.

Your thread remain open, and support are awaiting your reply.

1 Like