Can't update my New Nucleus - says Update required

Roon Core Machine

New Nucleus

Networking Gear & Setup Details

CISCO GB Unmanaged switch that works perfectly.

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I just purchased a new Roon Nucleus with 1 TB HDD from my Roon Authorized Dealer. Before connecting it I closed and quit out of the Core I previously installed on an old iMAC. I’m trying to get my new Nucleus to work but it is very frustrating.

I tried using a MacMini, iPhone or iPad all with Operating Systems that are up-to-date. I plugged the Nucleus on my Ethernet Network using my Ethernet CISCO Switch.
When I launch the Roon App a Nucleus icon shows with explanation about the Nucleus at Firmware 1.0 (build 175) stable/::fff: Version 1.6 (build 416) stable. Green circle appears below saying Update required. This screen appears to be asking me to Choose your Roon Core. When I press the blue Connect button on my iPad the heading is: Software update needed: Roon is trying to connect, but looks like one or more devices on your network need a software update. I see 2 items:
the First is Nucleus 1.6 build as noted about with a Red Exclamation Mark ! saying Retry Now in Red. Below, it says This Tablet 1.8 (build 970) stable and to the right it says Check for an update with a black Apple logo and wording saying, Download on the App Store Download. My iPad is up to date. When I press Retry now I’m returned back to the screen asking me to Retry now. If I go back to Choose your Roon Core and press the bottom link to Configure Roon OS Devices on your network: It shows the Nucleus at an IP address of and says Done. But if I press the IP address I’m brought to a Roon Nucleus screen where everything says OK and the Networking, Ethernet is set to DHCP with IP Address with Netmask and Gateway and DNS Server It asks if I want to save it.

I’ve tried reinstalling the Operating System which says it was successful but the version doesn’t change, and I tried rebooting several times. I tried hard rebooting with the button on the back of the room Nucleus device. I’m hoping someone or support from Roon can help me. I don’t know how to get this Nucleus to work which cost me a lot of money.

Your nucleus is at a really old level of software, surprising coming from a dealer.
Your clients are on a much newer version and can’t connect.

You need to update the nucleus software, by connecting to the web page of the nucleus.
The guide to making that connection and doing the update is here.

I appreciate you trying to help me. I’m surprised too that its so out of date. I just bought it today. The instructions you sent me don’t make sense. I accessed the link to RoonOS web you provided. I click on the line Configure Roon OS Devices on Your Network but a pop-up appears listing the Roon OS Devices as a Nucleus with my version1.0 (build 175) stable Serial number: containing the serial number of my device. When I click on the pop-up content about my roon nucleus it brings me to a screen with Roon Nucleus System Status. There is No Set-up Tab and No way to access System Settings. Each heading under System Status including Operating System has a blue button saying Reinstall.
Roon Server Software heading with my version and build has a blue button saying Restart;
Internal Music Storage shows the 1000GB HDD with 924GB available and allows me with a blue button to Format it. Then it show Roon Labs Software OK and a heading called Roon Database ad Setting saying OK 100% of 114GB available and it has a blue Reset button beside it. There is no other way to access Setting for room. Hoping you can help me.

Hit the reinstall button. Can’t do any harm on a blank system and may get you up to a level that will work.
I’m just a user like yourself BTW.

Thanks, I tried that twice but no luck. Its still saying it needs to be updated but keeps coming back to a Retry Now red button. Do you know how I can get Roon Support for this?

In the first instance I’d contact your dealer. Roon @support will see this thread.