Can't Update Nucleus From Build 416 [Solved - Try Again]

New user and Roon subscriber here trying to use his Nucleus for the first time. I seem to have the same problem as Janusz.

After starting Roon I see this:

Tried retry several times, to no avail.

Trying to do it through the web interface I get this:

Pressing reinstall then seems to work at first, but after that Roon keeps giving the same message that I need an update. Also restarted the server software, and the Nucleus itself. No success. I don’t get any further.

Running Roon on windows 10, the Nucleus is connected to the net with an ethernet cable.

Just fired up a new Nucleus for the first time this morning, same symptoms.

@Dylan I’ve got the logs for my Nucleus here:

It’s a Revision B Nucleus, Firmware 1.0 (Build 175) Version 1.6 (Build 416). Have reinstalled/restarted everything from the web UI and power cycled related equipment, still get ‘There was an error checking for update’

just do an Operating System Reinstall see if that helps…even tho this option doesn’t wipe out any database - you should have a backup…if not then you just have to do it anyway I guess. I’ve done this many times and Database etc is untouched.

DO NOT “RESET” the Roon Database and Settings!!!

Had already reinstalled Roon OS 2-3 times from the web UI page via ‘Configure Roon OS devices on network’

This has worked for me in the past, do check your DNS settings for or to see if this helps

Yep, I tried the same things as Ben did (reinstalling Roon OS) several times using the web interface. Didn’t work. Resetting the Roon database is about the only thing I haven’t tried :wink: Although I don’t think it would be a big risk in my case since it’s still empty.

What about the DNS settings? I don’t get what you mean.
[update: I have reinstalled the OS with the static DNS address replaced by both and now, but none of that made any difference either.]

Will have to give it a try Monday when I’m back in the office :+1:

It would be really nice if Roon @support could help too. My shiny new Nucleus is still not working after several days.

@support I am having the same issue as described above. Please help! Thanks in advance! and Google DNS didn’t help (including reinstalling after changing).

Hey @Herman_Beun,

Thanks so much for bringing this up - I’m sorry you’ve had to deal with this. Based on the below post, it looks like the issue is now resolved for you:

Please, let us know if we can help with anything :nerd:

1 Like

Hi @beka

Yes, I don’t know what was changed, but it started working spontaneously after a few days. Everything is fine now :slight_smile:

Thanks again!

1 Like

Hi @Herman_Beun ,

We made a server-side change here, glad that it resolved the issue on your end!

@Ben_Hagens - Can you please try again and let us know if the update is working correctly on your end as well? Thanks!


Thanks again! I’m happy!

1 Like