Can't upgrade to 2.8?

i5 here. I hit the upgrade button and the upgrade goes through all 3 processes. Says complete.
I reboot and still on 2.7. Not sure what else to do.

Same here, older i7.

Take a look at these instructions under the FAQ tab when you log into “My Sonicorbiter”:

Very helpful, thanks!


Thank You…I forgot again that there was more to do than pressing the button.

Followed the instructions above but after rebooting and trying to get to the next stage (as described), system always repeats stage1 …

Yes after getting Andrew’s email yesterday I tried to follow the update instructions but could never get past Stage 1. Finally rebooted for the 19th time and went to bed. This morning I tried again and got a much longer Stage 1 sequence. Following the instructions I rebooted and put in the upgrade28.php address again and VOILA Stage 2 ran through and now my System info shows 2.8. I must have run the upgrade link thing 10 times. I suggest you just keep trying and maybe wait a bit (like 20-30 mins or more) between Stage 1 and Stage 2 updates.