Cant use Tidal with roon anymore

Hello. Im getting Tidal error in Roon. Qobuz is fine. Tidal works flawlessly on my phone with UAPP and by itself. When i log on Tidal in Roon it shows: “No streamingfornats available”. And when trying to playback a track it says: “This track is not available on Tidal”. It had been like this for a week. I have tried to log in and out, restart PC and Roon etc nut nothing works.

What to do?


Hey Thomas, sorry for the trouble logging in to TIDAL! Could you try clearing the TIDAL cache?

  • Exit out of Roon
  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

@kevin Sadly ghis doesnt work. Still the same. Tried it several times to move the map contents to another place on my lapto:( dont know what do. Been so for over a week.

Hi - I may be having the same problem (macOS Core) - tried clearing the cache folder, logging in/out of Tidal service and rebooting but roon says that Tidal is slow and I may have a network issue

Tidal app works fine

I’m also having the exact same problem right after I signed back up with Tidal’s free tier. I added it my account to Roon and tried to play any track in Tidal and get same error message as above. Please advise.

I had the same problem for a few days and realised that I had been booted off my Tidal subscription in Roon. I have no problem logging in to Tidal and my account (Tidal Premium) hasn’t changed. I’ve tried rebooting all components and relinking my Tidal account to Roon. It gives me confirmation that this has been done with the green tick in a box but Roon still can’t see my Tidal account.

I’ve also cleared my Roon cache twice and still same issue

Anyone who knows a solution or can help me?

@kevin any more suggestions please on what to do here please?

Same problem here. Can sometimes stream but meta data is all dorked up.

Are you on the free Tidal subscription? Apparently that is not supported on roon.

Same issues continues with Roon installed on MacOS as on IOS.

Roon does NOT work with the Tidal free tier.

This has been confirmed by both Roon and Tidal.

Your now on the free tier if your on Premium which not supported on any other platform than Tidals own app. You should have been offered to change to Hifi. You have to be subscribed to Hifi or Hifi + to use Tidal with any 3rd party.

Thanks Simon but Tidal switched me over from what used to be called “Premium” (which doesn’t exist anymore) to Hifi. So I’ve been on Hifi and have the same issue…I don’t get any error messages throughout the linking process in fact it confirms on the screen with a tick in a circle that my account has been linked but then Tidal does not appear on Roon and all Tidal tracks on playlists can’t be found.

Strange I just resigned up on launch of the new hifi tier here in UK and had no issues, but my account was hifi before so maybe that’s why?. Have you tried logging out from Tidal in Roon. Clear Roons cache and then sign in again. Might help.

I’m not actually logged in to Tidal in Roon. Each time I try to login in I get the screen with a tick saying Roon and Tidal are linked but there is no Tidal. And the Services screen shows no Tidal login. I have cleared the Roon cache a few times and tried this.