CCU Predictably Freezes After First Track; Requires Server Reboot


(JohnV) #1

At first I attributed this behavior to my habit of making live tag edits while listening to music.

Today, no multitasking going on.

First cut was a TIDAL album (Volodos Play Brahms). I then played two other performances of an Intermezzo on my local drive, selecting both starting at the composition page.

The CCU didn’t make it beyond displaying the first cut.

A Roon ROCK server reboot will fix it for awhile.

In a word, inconsistent. In a few words, nice when it works.

Setup in profile. Current on all.


(Noris) #2

Hey @John_V,

Is your CCU up to date? I’m not sure what you mean by “beyond displaying the first cut”, can you expand on that a bit? If you can reproduce this issue at will some timestamps would be good to have.

Thanks,
Noris


(JohnV) #3

Thing is, I haven’t been able to pinpoint any causal factors. After a reboot, the problem tends to go away for the day. It’s just the persistence of the event: 4-5 times in the last 20 days. Not a calamity by any means.

Early on, it was dropping signal, but I eventually diagnosed a bad cable. I haven’t updated it since the initial purchase, so if hasn’t upgraded itself, that may be a factor.

Anyhow, just a report for now. I’ll try to stress it and see if I can replicate it. Thks for writing. J

P.S is there any technical reason why performing a “live” update of audio files, using a tagger, while playing music might cause the CCU to lose signal or freeze? That’s the only unusual activity that I can think of.


(Noris) #4

Hey @John_V,

I don’t see how this can happen because of live-tagging the files so I’m thinking it might be something else. What is your network storage like for those two Intermezzo tracks? Are they from a USB or SATA hard drive? If you can stress test and reproduce, let me know and I can ask QA to take a look.

Thanks,
Noris


(Noris) #6

Hey @John_V,

I spoke to QA about your issue and we would like some more information here. Can you let me know:

  • How is the CCU connected to the internet? Is it using WiFi or is it using an Ethernet adapter?
  • Are you using the original power adapter that came with it or another adapter?
  • What exactly do you see when it “freezes”, can you post a screenshot?
  • Have you noticed any kind of pattern from the media you are playing back?
  • When this issue occurs, do Web Display zones work as expected?

Thanks,
Noris


(JohnV) #7
  1. The CCU is connected to my AV/Receiver via HTML. Then, ethernet cable (cat 6 or 7) runs from the CCU’s adaptor (stock model) to a passive switch. I had been previously experienced dropping CCU signal but switched out a bad cable. Not sure I have a spare brick to try. Pls advise if that’s the next step.
  2. Yes
  3. Screenshot shouldn’t inform you. It is the normal display of the first track’s contents. And, the background photo rotates among the Album Artists. But the text and album cover stay stuck regardless of future track changes. And never again after a Core reboot, until the next day. hmm…
  4. No media patterns, whatsoever. Three very different first tracks.
  5. No other Web Displays used. OR, I don’t quite understand the question. :slight_smile:
    HTH, and thanks.

Random thoughts: My CCU settings include use of their Art screensaver mode. Works well…except for this episode.

BTW, I usually boot Roon from a Logitech remote with all kit up and running. I hit the play button immediately after Roon is chosen without waiting for the screen to display anything. The Roon splash screen doesn’t appear; it goes straight to the track display in sync with the sound. [All of this seems extraneous to me, but there you go.]


(Noris) #8

Thank you for confirming that info for me @John_V.

Just to make sure I understand you correctly, the photo changes with each song but the track name and track artist remain unchanged?

As for point #5, can you please try setting up a Web Display zone to a PC running Chrome or Firefox and let me know if that is also affected by this issue? This way we know weather to take a closer look at the CCU or at Roon for the cause.

Thanks,
Noris


(JohnV) #9
  1. Well, the photos continue to rotate among the Album Artists, but if the track has only one artist, then I’m stuck looking at him/her. Make sense?
    Tomorrow, I will drink my coffee FIRST before I start Roon so I can confirm in the a.m.

  2. Will my MBP, which I’m using for my remote, suffice for the Web Display? I guess you’re wanting me to set one up and observe whether the WD and CCU are in sync with their respective displays, right?

I just tried to replicate the morning’s events by shutting down everything, and then pretending its a new day. No dice; everything worked as expected. So, the experiment will have to continue tomorrow.


(Noris) #10

Hi @John_V,

Yes for your point #2 that is my intended test here, to see if they stay in sync and the MBP that’s a remote would work great for this test :slight_smile: . I look forward to hearing your results tomorrow!

– Noris


(Tim) #11

@John_V

I have a CCU connected to a 4K TV via an HDMI port. I don’t use it all that often but I have never noticed the behavior you described. Happy to test and see if I can reproduce the issue.

Do you have your CCU setup as a Zone and are sending audio to it or are you using it as a Display?

Tim


(JohnV) #12

Thanks for your interest Ted. I had mine connected direct to the TV but I didn’t want to have to shift to a different HDMI port each time. And Google support said the preferred hookup was via the A/V receiver.

As for your second question, it appears as a Zone (see below); I’m guessing that’s because Roon sees it as an endpoint. But, I don’t have it grouped with anything else. Display only…


(JohnV) #13

This morning, at 7:35 CST, I:

  • Started up the Roon Remote (Core runs continuously), created a web display, chose an album (a TIDAL Mussorgsky album), hit Play, and then hit Logitech Harmony Remote/Music remote button. With everything on already, the only action taken by the Music sequence was a change in the Receiver’s (Anthem MRX720) input channel.
  • When music starts to play, the CCU/TV displays album cover, progress bar, and titles, and the three Album Artist’s pics rotate display every 5-10 seconds. All very typical. However, the progress bar never progresses during the track.
  • The Web Display, when first created, displayed the Roon splash screen. It never changed through four tracks.
  • Now on the fourth track, Artist pics still rotate on TV, track title and progress bar haven’t changed, and the Web Display’s still stuck on “Roon”.

HTH. Now, for my second cup… :slight_smile:

P.S. If Nighttime is the common thread, all I know that happens is a reboot of my four Ropiee/Rpi endpoints and amps. The ROCK stayed up for the entire night. No 1.6 upgrade. :slight_smile:

I haven’t rebooted yet. Pls advise when or if to do that.


(Tim) #14

@John_V

I started playing music to my CCU zone at 8:10 my time, about 1 hour and 50 minutes ago. The display on the TV is still updating with new album art and song titles with each new track and the progress bar updates as each track is played.

My Roon core is running on a NUC running Windows 10 and I’m running the full Roon app
My CCU is connected via WiFi

You mention seeing the three Album Artist’s pics rotating every 5-10 seconds. Do you mean the big background picture or the small album cover picture in the lower left corner? I chose to shuffle a 138 track Diana Krall playlist so my background mage has been constant. The album cover in the lower left corner has changed with each track except in those instances when two or more tracks were from the same album. I never saw more than one album cover for a track.

I’m going to switch to a different playlist with multiple artists so that the background image will change. I don’t know if I have any albums with multiple cover art images, I have not edited any metadata and most of my library is from Tidal. I’ll report back as soon as I see how the new playlist performs.

Tim


(JohnV) #15

The background picture. Particularly for classical, it is not uncommon to have several Album Artists. I infer that Roon detects this and rotates the pics every so often.

Me neither. My problem is the album cover and title were not changing when appropriate.

Thx.


(Tim) #16

@John_V

I just checked on the CCU display and everything seems to be performing as expected after 15 minutes of play. Selected playlist is all local hi-res albums so the progress bar is not only updating but showing the wave form instead of the solid bar. One of the albums in the playlist is Deja Vu by CSN&Y and it has multiple album artist images because I saw them change.

So far the differences between your configuration and mine seem to be:

WiFi vs wired Ethernet for CCU connection
Core? I’m using Windows 10 not sure what you are running

Not sure if either of the differences are significant. Probably difficult to change your core if it’s not Windows based. Have you tried using the CCU on WiFi?

Tim


(JohnV) #17

Thanks again for your interest. My core is Linux (ROCK Nuc).

And, no, haven’t thought to try wireless. But when i first bought the thing and installed it wired, it kept dropping signal. Turned out to be a bad cable.

Just out of curiosity, what other settings do you have for your CCU? Do you use their screen saver? I do, with the fine art photos.

Noris mentioned there was something funky in my logs that they’re investigating. I’m going to pause my troubleshooting and let them run with it. Noris or I one will report any findings.


(Tim) #18

@John_V

Just checked and the local playlist has been streaming to my CCU for over an hour with no display issues.

I checked my CCU settings, it is not in any Groups. I have Ambient Mode ON, Guest Mode OFF, Preview Program OFF and I let others control my cast media. System firmware is 141427 and Cast firmware is 1.36.141427.

Tim


(Tim) #19

@John_V

My CCU has now been playing for over four hours and the display is still up to date and updating as expected. The playlist finished so it’s on Radio now and mixing in Tidal tracks with tracks from my local library.

Tim


(Tim) #20

John,

Stopping play to my CCU after just over 7 hours so I can use the TV for my daily YouTube fix.

Display still up to date and updating. I know I’m just one data point but it appears Roon can stream to a CCU successfully for an extended period of time.

Good luck … Tim


(JohnV) #21

No offense, but I was misery wanting some company. :wink:

Seriously, there are still a number of options for me to pursue. And, perhaps I should just reboot Roon at the beginning of the day anyway, 'cause that’s all it takes to fix it.

But it’s a curious puzzle. Thanks again.