CD box with more than 100 discs

Details on your Core machine (Synology DS720+, Roon build: how to find this?)
Details on your Remote(s) (Windows10, Roon build: how to find this?)
Networking details (Ethernet)
Library details (where your music is stored: Synology diskstation DS720+, how many tracks are in your library: many)

My problem:
I ripped all 107 CDs of a 107 CD set called “Karajan 1938-1960 collections” and placed them under Roon. The library showed all the contents from disc2 through disc99 as normal, but those in disc1 and disc100-107 were all classified as disc1. As a result, disc1 is showing many track1 pieces (see figure). Does Roon not support more than 100 discs?

Please ensure that your disc folders follow the naming convention recommended by Roon; i.e. CD1, CD2, …CDn, rather than disc1, disc2, etc.

Roon supports boxsets with more than 100 discs, but they have to be numbered or tagged properly. If roon is failing to understand by the subfolder names which disc is which numbers, you have 2 options:

  • tag all disc numbers properly using MP3tag or alike
  • tell roon manually which disc has which number by using the Edit album > Fix Group tracking and correct all disc numbers shown in red (i.e. contradictory) manually

If roon cannot sort out which track is on which disc number bearing the wrong #1, you might have to manually pick the tracks and renumber their disc using ´group tracks´ function

Thanks. Actually, I did not sort each CD in the box but put all 1403 files in the same folder with the names like “1-01 Mozart.m4a”, “1-02 Tchaikowski.m4a”, “1-03 Beethoven.m4a”, …, “117-26 Strauss.m4a”.

Each of them are tagged likewise using MP3tag.

I probably need to "manually pick the tracks and renumber their disc using ‘group tracks’ function, but too many (sigh)

The file names are not (or not predominantly?) relevant, at least when the file tags don’t have the correct disk and track numbers.

I suggest that you read the documentation that was provided and do it as it’s documented. As there are currently problems, maybe double check everything. If only to rule out causes other than a Roon bug.

Thanks. Well, I don’t rely too much on file names. But, the official help center suggests put such file names" FAQ: How can I ensure multi disc sets and box sets are identified properly?. In any case, I tagged all 1403 files from the 117 discs properly, like disc number 1, track number 1, and so on using MP3tag and put all of them in the same folder. Still, Roon recognized track1s from disc1, disc100, disc101, … disc117 as the same 1-1.

It also says „make sure the file tags include“ and other things. It may well look at file names, but I suppose prioritizes file tags in case of conflicts.

If there wasn’t a problem, there wouldn’t be a need to investigate, but as there is a problem, all I’m suggesting is to do it exactly with one of the methods that are explicitly mentioned, and double check everything.

If it still fails, you can then at least state that you did everything as in the docs and it still fails, which would make your case much stronger

Double checking is a good idea, I’ve attached three snapshots for this purpose. The first snapshot of the roon screen


shows multiple 1-1s, the top 1-1 being Credo in Bach:Mass. The second snapshot


shows the file info for this piece, and here we can see that the file name is “109-01 Bach_ Mass In B Minor, BWV 23.m4a”. The third snapshot

shows the tag info of this file in MP3tag, which shows that the disc number of this file is 109 and the track number is 01. How does roon recognize this file as 1-1? Just in case, the second 1-1 in the first snapshot is actually 108-01, which also appears in the third snapshot.

Well, personally I would follow Roon Labs recommendation of using subfolders named CD1, CD2, CD3, CDnn instead of having one folder containing thousands of files - that has been shown to cause other performance problems.

And looking at that Mp3tag screenshot I can see issues with your metadata that may be tripping up Roon’s identification process.

Artists should be separated by the “;” character, not a “,” or a “:”. And Roon Labs explicitly advise against putting dates in the composer name; see:

1 Like

For some unknown reason, Roon is ignoring the disc number in the tag and not recognizing the syntax of the filenames discnummer-tracknumber.

I guess it would help to migrate the wrongly identified discs´ files into their own subfolders ´CD101´, ´CD102´ and alike as Geoff has suggested. The other variant would be to change the disc number manually in ´fix track grouping´. I have a similar case with ´Vol. V´ not being identified correctly as disc 5. Fixing it was very easy by manually correcting the disc number:

I have already tried this: migrated all the files into ‘CD1’, ‘CD2’, ‘CD3’, …, ‘CD117’ without success.


'109-01 Bach_ Mass in B Minor, BWV 23.m4a" in ‘CD109’ folder is still recognized as 1-1.
Now, I have to try your method. I know I can do this, but extremely tedious because there are numerous 1-1s, 1-2s, and so on. Thank you so much any way.

It is best to completely remove the whole boxset from the filesystem and then delete it from Roon’s library first. Then re-introduce and reimport it. Otherwise Roon tends to retain old information.

1 Like

It might be easier if you disable the general folder and point roon´s ´settings > storage´ management solely to the disc you want to edit as the next one. CD109 in this case, and then proceed with CD108 once this is done. Then you would see only a fraction of the boxset and can renumber it to disc #109 without having to sort out which ´track 1´ is belonging to which disc. When re-activating the whole folder you might have to merge all separated albums. It is a bit of work but doable.

What I did was exactly what you recommended. It did not work unfortunately.

Did you also complete Library maintenance before you re-imported the discs?

Yes. The library was cleaned up before re-importing the box files.
What I haven’t done is totally reconstructing the library. I am reluctant to do so, but should I?

I don’t know that resetting the database and reimporting everything would produce different results. If you’ve got the recommended folder structure now, i.e.:

Herbert von Karajan / Karajan 1938 - 1960 Collections / CD1
/ CD2
/ CD3

/ CD109

then I suspect the end result will be the same. I don’t know why it isn’t working in your case. Perhaps this particular box-set isn’t known to Roon - but it still should not be mixing up tracks from different discs.

Strange enough, when I removed the CD100 folder, the remained CD1-CD99, CD101-CD117 were recognized just fine. There is nothing strange at all in the tags of the files in CD100 of course. When I put this CD100 folder back in the “Karajan 1938 - 1960 Collections” folder, suddenly there were many 1-1s, many 1-2s, … appear. I would say that this is a bug of some kind. I will try to keep away of CD100.

1 Like

Very odd.

Can you show us a screenshot of Mp3tag’s view of this folder so that we can see the metadata being used?