CD ripper not working

I have a roon nucleus as was ripping CDs to a USB and them importing to the NAS attached to the nucleus without issue. Now, despite the Nucleus “seeing” the CD ripper, the CD doesn’t automatically rip when inserted in to the drive. I have tried a nucleus reboot and power cycle to no avail.

What versions are you running on the nucleus - a screen shot of the web GUI should give support everything they need

Current versions should be these

This is what mine displays. However no CD ripper is plugged in…

Hi @Stuart_Hastings,

Can you please try a full power reboot on the Nucleus to see if this helps?
Power off Nucleus -> unplug power cable -> wait 30 seconds -> plug back in -> power on

I have my core on a Mac Book Pro. Until I came across posts about there being a cd ripper in ROON. News to me!

However, Roon only sees my Apple Superdrive as a storage device. Yet it still put all the info from the disc in it into my library. It just didn’t copy any files. My drive though made noise as if it was trying to copy or something. This was a brand new cd. I copied it over using dbConverter.

The cd ripper option is only on Roon OS devices like Nucleus and ROCK

Thank you, Wizard.

Hi Stuart,

I was just wondering if you had got this resolved as I am having the same problem with my NUC running ROCK.

I used to rip the odd CD I purchased but now it doesn’t show up.

Yesterday I Downloaded the ROON ROCK OS and altered the NUC BIOS to clear it. Then overwrote with the new download. ROON restarted fine and- da da da (pause for effect) it was exactly the same as it was before I started. (Loud Grown).

The guys in the Help Centre have gone a bit quiet, which is always a bit concerning.

Anyone got any news/updates. Any updates much appreciated.

Happy listening.


Hey there
Nix, nada. Still the same problem. I’ve taken to ripping through iTunes and transferring manually

Hi @Simon_Huxtable,

Is the CD showing up under the ROCK /Data/Storage/ or under Overview - Recently Added in Roon? It is possible that this album was wrongly identified but still added to your library.

Thanks Noris,

You got me thinking outside the box and to look closer.

I first looked in ROON, found the Album (labelled as a CD) and played all tracks. I was so busy looking for the CD Ripping File in the Network/ROCK/DATA file where it used to be stored I didn’t look any further.

The file was hiding in between Budgie and Christmas folders in my MUSIC STORAGE folder.

I can now move it to the RAY LAMONTAYNE folder and get things in order and settle back and enjoy it once again.

I used to use Tidal but “grumpy old man” Neil Young put pay to that so I swopped over to Qobuz and bought the CD’s of the Albums I could not find on there system.

All the best and thanks for your help.

Si and Debs UK

1 Like