CD Ripping No Longer Working At All [Solved]

Got the CDs today. Ripped both successfully one after the other (maybe max 10–20 min in between, were not waiting for the first to finish and didn’t check time). Both were ejected automatically. Apple SuperDrive in combination with NUC7i5BNH.

I am having same issue. I thought it was a fault with my nuc/rock. I can rip one or two CDs and then it stops working until I completely turn off the rock and reboot manually Rebooting via my network browser does not work. I even bought a new cd drive as initially I thought that was the issue.
I am glad it is not only me as I was considering sending the NUC for a repair.

1 Like

Hello @Jeff_Z, my apologies entirely, I mistook Martin as the OP. I will also add an item for our QA team on your behalf and return to this thread with their feedback shortly.

CD ripping has been going well lately. i haven’t had to reboot in a few days.

Update: I have had to reboot several times to get the CD ripper working again. The problems from the past are back.

So what’s the latest on this? I’m in the same boat. I even purchased a 2nd drive and same problem. So Roon’s support has been aware for a couple of months and no patch? A little frustrating. I’m less concerned about the bug than the time it’s taking for a fix…I was ripping weekly and now not at all. I have a lifetime license…beginning to have some regrets…

1 Like

I’ve given up and gone back to using EAC, poor state of affairs really.

I haven’t ripped in a while. Last time I did, I needed to reboot my NUC every day or so to reset the ripping feature so that it would work.

I purchased my third CD reader last week and still am having little success. When it does work it is after a hard reboot, but still intermittent. I am not seeing any responses from ROON support. A “we’re working on it, but don’t have an fix” would be wonderful. At this point I wonder why no response.

1 Like

Impending 1.8 release I imagine.

Bliss…finally found a cd ripper that works with Roon Nucleus. LG usb drive from Best Buy. But I feel kind of stupid. I can’t locate the page in Settings that shows the attached CD drive status. Would someone be so kind as pointing me in the right directions?

Much appreciated.


in the Roon app, go to settings and you’ll see the IP address of your nucleus. enter this address in your browser and the web-interface to your nucleus will come up, including the status of the cd ripper.

Have the same problem with my Nucleus Model B bought two weeks ago. I thought it would be a problem with my two disc-drives and now I stumbled over this discussion. It’s quite annoying to restart the nucleus even not knowing if it will rip the next CD or not. Moreover I have to make a hard shutdown because one short press on the powerbutton did it once and since then there is no reaction on a short press.

The fact this has been ignored completely by Roon is rather disappointing. Something that worked flawlesly for so long then one update and its broken @support is this ever going to get sorted?


I cant‘t understand that Roon doesen‘t do completely nothing about this a couple of months old problem. It all worked before. Also turn off the Nucleus with a short press of the button on back side. But that has not worked for at least as long as the error when ripping a CD.


This is still a problem for me. Nucleus+ and a HAIWAY USB 3.0 drive. reboot or a hard restart fixes it temporarily. I’m trying to burn 100’s of CDs from my collection and it’s a real pain and disappointment for the price of the Nucleus+ to see its been an issue for so long.

I realize this is a real disappointment to you, but you really should consider another method of ripping your CD’s? There are many ways ranging from free to costly, where the results are far more predictable and portable than using Roons “bonus feature”.

Are you comfy with computers? An old PC with a CD drive can easily be transformed into an automatic ripper with, say, Vortexbox OS?
(No cost for function, only hardware)

I’m very new to Roon. I ripped one cd a week or so ago. Worked fine. Now it does not. Eject button in interface does not work. Rebooting NUC using wee red button in interface has no effect. Bit reluctant to do hard shut down just to rip one cd. Will this be fixed?

It will be fixed, but there’s no timescale of availability at the moment. It’s a known issue, see:

Thanks for your prompt reply. If I really need to rip, I imagine I can do so via my pc.

As a newbie: when something like this gets fixed, will there be a notification on this forum, so everyone who participated in this thread gets an e-mail?

It will be noted in the Software Release Notes category of the forum - in this case by a post giving the Software Release Notes for a new build of Roon OS.