CDs Not Loading or Ripping to Nucleus

I have attached a CD ripper to my nucleus and it does not consistently rip the CDs to Roon. I’ve only been able to rip two or three in fact despite trying with multiple CDs and multiple attempts with the same CD. Could it be the CD player? Any ideas? Very frustrating as I would love to use all this downtime to upload my CDs to the Nucleus.

Thanks for any thoughts…


Are you loading the discs one after the other? Try closing the drive without a disc and wait for the check to realize there is no disc in the reader. Then try again. This worked for me once before. I have not ripped discs back to back in a while.

Tried that, but still nothing. The CD player cranks up, but then just stops.

Honestly I would use dBPowerAmp or Mac equivalent to rip to the PC and then copy across to the Nucleous. That will a) be quicker and b) ensure you have a back-up on your main computer.


What is the CD Drive make and model?

It is an HP disc drive. Not sure of the model number. Recently purchased.

I’ve had similar issues. Nucleus will rip several CD’s without any issues, then abruptly quit. Rebooting seems to be the only way to get it to work again. Can’t isolate it to any single action or cause, other than it occurs more often while I’m concurrently playing files and ripping CD’s while listening. Other than that, a great product.

Best recommendation is to try a reboot and see what happens.

Good luck!