Change wifi on app/roon

Roon Core Machine


Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I’m changing the wifi throughout the house and can’t figure out how to change the wifi used to communicate between the app on my phone and the nucleus. It is not clear to me how to change the wifi used on the nucleus. It runs a wired connection for music streaming, but wifi for picking music using my phone.

Welcome to the community, @Scott_MacLeod.

No action is needed in Roon; the Nucleus doesn’t use Wi-Fi. Once you have replaced the Wi-Fi, you’ll need to connect your to the new SSID.

If you still have difficulty, please describe your network in much more detail, and include details of the devices you’re using.

Thanks for the quick response. I presume the missing word in your answer is “phone”. When I connect the phone to the new wifi in the house I cannot find the Roon core. When I connect to the old wifi it shows up again.

That is probably because the new Wifi has created a new network of which the nucleus is not a part but the phone on wifi is. Roon and its control and endpoints all need to be on the same network, as identified by the sub-net address. Check the IP numbers of the nucleus and the phone, the first 3 number groupings need to be the same. If they are different then they are on different networks.

There are a couple ways of going, but, not understanding exactly what you are doing/going with your network I can’t make specific suggestions.

However, some generic suggestions: If this new Wifi is just for Wifi, then it needs to have its DHCP setup turned off, so that the original router is supplying the IP numbers for the whole network. Or, remove the original router and just use the new router, plugging the Nucleus into that, which should give the Nucleus a new IP in the same network as the wifi devices.


Issue is resolved. I had the hub connected to both routers. I’ve disconnected the old one and now am communicating with the Nucleus via the new wifi.

Thanks for the help.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.