Changes not noticed [Ticket Open]

i know…but this is not the way it should be…
a hole rescan of the library is working but take a lot of time and energy (green computer) …i would need to rescan after every change? before with a roonserver on windows every change was noticed and direct… so is this a bug in rock?

1 Like

I’d not say it was a bug in the Roon application, but different Operating Systems and SMB implementations interact differently.

I’ll drop a tag for @support to follow up with you.

In the meantime can you describe your Roon setup (hardware, NUC, NAS, Network, …)


-rock intel nuc 7i7 via ethernet to home-network
-nas (synology only smb) via ethernet to home-network

  • allo usbridge via ethernet to home-network
  • dac to usbridge
  • diffrent endpoints…macbook and so on…
    -ipad remote

still no help? somthing wrong with my setup or a bug in rock?

Let’s tag @support for you.

Hi @latenz ---- Thank you for the feedback, and more importantly, thank you for your patience. My apologies for the slow response.

Moving forward, I know you had reported some trouble getting the NAS to mount in ROCK. My assumption is that none of your SMB settings have changed and you are still using SMBv3 or SMBv2 as suggested in our knowledge base, here. Correct?

Furthermore, can you give me some insight into the “changes” (on your NAS) you are referencing that ROCK is not picking up? Having an idea of what you are doing procedurally speaking, would be very appreciated as well.


i´ll try to remember what i changed…only small things…more or less everything was running well in roon-server-windows surrounding…
i changed to rock an now i was not able to access the files from my synology nas . i used the same ethernet-port from before…

so i changed…

  • on the nas - in advanced settings - min smb-protokoll was smb2 and i changed to smb1
  • i enabled transfer log
  • and i gave the nas a fixed ip no more dhcp
    thats it - i think…

Hi @latenz ---- Thank you for touching base with me and providing the requested feedback.

Moving forward, I would definitely switch your “minimum SMB-Protocol” back to SMB2, because as noted in the knowledge base link in my post…for best performance we recommend the use of either SMBv3 or SMBv2.

Furthermore, we’ve found that many NAS devices have issues properly communicating changes to the device they are communicating with. This behavior appears to be more pronounced with OSX based cores, but we have had reports of this occurring on other operating systems, as well.

Basically, when the OS is aware of a change on the network drive, it lets us know and we update your library immediately, but we don’t always get that notification in as timely a manner as we would like. However, in certain situations the OS can be unaware of changes, particularly if they are made directly to the network drive. If the OS fails to notice the changes, Roon isn’t notified, and the changes don’t show up in your library until a rescan is triggered.

Unfortunately, we’ve found that most NAS’s just silently report a subset of events, or none at all. We did some research and found that just about every piece of software that attempts to do “real time watching” on NAS’s eventually runs into this limitation, and supplements it with a periodic scan of the storage folder. Plex does it, JRiver does it, so do others, and so does Roon.

Brian discussed some of that here, although I should mention that a few things have changed since then. We have some new plans for improving our real-time scanning, but I don’t have a time frame to report on when that work will happen. In the meantime, we’ve also made the rescan period configurable, so you can have Roon scan more or less often depending on your situation.


I’ve used Roon for a year now. My music has been stored the same way all the time, on an unRAID file server. In periods the auto detection if changes (new albums etc.) hasn’t been working, forcing me to run a full rescan. I see in the forum others also struggle with this. The other day I decided to try figure out why this has been working sort of “flakey”. I ended up making some changes to the unRAID setup. Since I started using Roon my fileserver has been configured to make hard drives spin down and sleep after a certain amount of time with inactivity. I changed this, now the drives aren’t spinning down. And auto detection of changes/new albums in Roon has been working stable for soon one week. Not quite sure if I have managed to fix anything, but it might be worth looking into for those who struggle with the same problem. Maybe especially those with a NAS unit. My impression is, a lot of those are preconfigured to make drives spin down, the same way I had configured the unRAID system of mine.

hi Eric …
when I change the min smb protocol to smb2 rock can not find any file? changed back to min smb1???
any idea

I have the same problem with my Synology DS1812 NAS - have to force a rescan of the folder every time I add a new album, if I want it to appear quickly.

Hi @latenz ---- Thank you for the follow up and my apologies for the slow response here.

Moving forward, just to confirm, when you switch to SMB2, ROCK is not seeing any files in your library, but when using SMB1 the content is present, Correct? Furthermore, is behavior consistently reproducible?


hi eric

right you are…when i set the minimum protocol to smb2 rock is loosing all files. when i turn it to smb1 everything is back again

Stupid question maybe, but what is your rescan interval set to? I realized that mine was set to 4 hours, and before i understood that I forced rescan all the time to get albums to appear immediately after import…

I confirm, this is also 100% reproducible on my side (ROCK + Synology DS115). ROCK can only see files, when SMBv1 is enabled on the Synology. Disable SMBv1, and they’re gone. (But the share is accessible from other Windows systems).

I’ve read that before in this forum, for instance here.

I’m following this topic with great interest, as it is one of the very few annoying things in my setup… Changes in the file system take very long, to show up in the Roon database…

Really don’t know if the inability to mount SMB2/SMB3 shares has anything to do with that.
But I thought I’d share and confirm, just in case…:blush:

(By the way, I find restarting Roon from the web interface a much quicker workaround, than forcing a rescan through the normal UI… see pic below. Takes ~5 seconds to complete.)

I can also confirm this behavior on a Synology DS412, ROCK running on an Intel NUC7i3BNK.
Switching to SMB2 as minimum protocol and Roon loses the share.

So there is no solution?


I also reidentify and rescan and so on are not working at all…really dissatisfying…plz help
my hard/software is quite standard…rock, synology-nas and they are not working together like they should…

Hey @latenz – we did some testing here and we can reproduce the issue you’re describing.

We’re going to be investigating this further and then we’ll follow up here with more information. For now, just leave the minimum protocol at SMB1.

Sorry for the trouble!

1 Like

ok thanks for the answer- so now i know it´s not a dead end…