"Choose your core" on Android App

Forgive my newbieness, but I just switched from IOS to a Pixel2 on Android.

I’ve installed, uninstalled and reinstalled the remote Roon app.

I can access the core (running on a mac) from my other mac, so I know the network is working. I can do it from my iphone as well. I’ve checked to see that the Pixel is on the same network. It is.

But it keeps “looking for remote libraries”.

Any thoughts? I tried typing in the IP address manually, but that didn’t work either.


@support … this might have been spotted before on the pixel2

Is this the real the Seth Godin? Looks like him :smile:

Have you tried restarting the core machine?

yep, it’s me

just restarted

no luck

thanks for chiming in, wiz.

Lets see if the Roon boys chime in on monday and look for some diagnostics info. Can you try with something FING to see if you can see the server or ping it?

I’m not much of an Android guy but its sounding like a network kind of issue. Is it getting the Gateway and DNS addresses ok from the Router?

Hi @seth_Godin1 ----- Thank you for the report and sharing your feedback with us. The insight is very appreciated and my apologies for the troubles.

To help aide in our evaluation of this behavior you are experiencing with the Pixel2, may I very kindly ask you to please provide the following information:

  • Please briefly describe your network configuration/topology, being sure to provide insight into any networking hardware you are currently implementing (i.e router, switches, power line adaptors, etc). I want to have a clear understanding as to how your devices are communicating and the “tools” being utilized to make these connections possible.

  • You mentioned in your previous post that restarting your core machine did not yield a change in behavior with the mentioned remote. By chance have you tried rebooting any relevant networking hardware as well?


Thanks @eric

I’ll give an amateur answer, and you can tell me what you need.

I have a Macbook pro that uses Wifi to connect to a Verizon router, supplied by them.

On that some network, I have another Macbook pro, also using wifi

The core machine is running the latest version of Room. It gets the music from a PSAudio server, connected via ethernet.

The second Macbook pro can easily control the first one, using Roon as a remote.

We had zero power in our house for a week, so yes, every single thing has been rebooted, with no impact.


Thanks for getting back to me @seth_Godin1, appreciated!

Just to confirm a few items…

  • Besides the mentioned power outage, no other changes/“events” have occurred with your setup, correct? As a side note, I am glad power is back. We also lost Brian for a few days last week :scream_cat:

  • The only networking device you are currently implementing is the Version provided router, correct? No switches, range extenders, repeaters, powerline adaptors, etc? The reason for my asking is that I want to be 100% certain that there are no other variables to be aware of in regard to your network configuration.

  • Furthermore, you mentioned that music is coming from a PS Audio server. Please correct me if I am wrong, :innocent: but I seem to recall from a previous post of yours that you are making use of a NAS to house your musical collection. Please verify.

Lastly, can you tell me if either or both of the following tests yield any change in behavior with the Pixel2:

TEST #1:
1) Shut down your Core
2) Open Roon on your Remote
(Tip: If you are using an iPhone, make sure you keep it awake)
3) Roon should be on the “Searching For Core” screen
4) Start up the Core

TEST #2:
1) Start up your Core
2) Open Roon on your Remote
(Tip: If you are using an iPhone, make sure you keep it awake)
3) Kill the Roon app
Tip: If you are using Android please go to Settings > Apps > Roon > Force Stop
4) Restart Roon on on your Remote


Hi @seth_Godin1 ---- I was looking through my open support issues and wanted to touch base with you in regard to the above.

Please let me know if you are still experiencing troubles and I will be glad to continue troubleshooting with you.

Many thanks!

true confession: I saw all the steps and said, “it’s easier to just use my laptop.”

so I’ll wait for a future rev and try again.

thanks @eric for the follow up

Seth Godin! Love ya, man.