Chord Hugo TT2 ASIO exclusivity getting hijacked by Win11

Roon Core Machine

Roon Core on Win10 machine Roon 1.8 build 884 - intel i7 4770k 16gb RAM

Networking Gear & Setup Details

N/A

Connected Audio Devices

Chord Hugo TT2 > Matrix Audio Element H > Windows 11 PC

Number of Tracks in Library

Description of Issue

Recently upgraded to a Hugo TT2 and I am really enjoying it, but if a single sound comes from Windows while I’m listening in Roon, the sound distorts, and I get a pitch-shifted version of the windows sounds and Roon stops playing.

Using the ASIO driver in Roon. Downloaded latest drivers from Chord site.

Can you show the audio device page from roon for the pc?

1 Like

Here you go:

You might want to try wasapi as that allows more configuration to mute system sounds etc.
Roon generally recommends wasapi

https://help.roonlabs.com/portal/en/kb/articles/audio-on-windows#:~:text=WASAPI%20is%20Microsoft’s%20recommended%20method,to%20support%20pro%20audio%20software.

1 Like

Thank you! :slight_smile: I learned something new - had always assumed ASIO was the way to go. I will switch to WASAPI and test for a couple of days.

If you click that gear in your screen shot, you’d be able to enter device setup where you choose “exclusive” mode to fix your problem.

2 Likes

Thanks. This is only showing for the WASAPI device, not ASIO. Is that normal?

You’re right, quickly checked it with my SMSL M300MkII ASIO setup and there’s no such option either, but Windows sounds do not intervene here.
Might be related to the respective ASIO driver for the device in question; sorry for not being helpful…

1 Like

ASIO is always exclusive.

1 Like

Thank you for the help! Yes it is a little odd to me that per @Marian’s comment below, ASIO should always be exclusive yet anything from a Windows ding, to a Youtube video to a game will interrupt Roon and I’m unable to resume playback until I close the windows application making the sound and restart Roon.

This then begs the question, why is Windows able to hijack the device?

Sorry, I wasn’t clear. Also, I’m no ASIO expert, so I might be wrong, but as far as I know, ASIO is always “exclusive” in the sense it accesses the device directly, bypassing the OS audio stack. Because of that, the OS is not aware of ASIOs use and lets other apps take over the device if “Allow applications to take exclusive control of this device” box is checked in the Windows device’s Advanced properties.

2 Likes

Interesting. So from my understanding I have 2 choices here:

  1. WASAPI + Exclusive mode checked in Roon device settings

  2. ASIO + “Allow applications to take exclusive control of this device” unchecked in Windows device settings

Given the support doc url that @ged_hickman1 cited, I am assuming the former is the optimal solution here?

Probably. As in all things computer and hifi see which suits you best

1 Like

If WASAPI supports all the formats you need, #1 would be the safest choice. On my Win10 system with a Topping D70, if I use ASIO and Roon is playing, the OS can’t get a hold of the device anymore, regardless of whether I allow apps exclusive access, so my case is different. Possibly different ASIO driver implementations.

1 Like

Thanks all!

Hey @MattG so sorry that we were late in responding to you! I truly appreciate your patience and the fact that so many others were happy to hop in and help!

I was hoping to check in and see if you were you still experiencing any issues? How did switching to WASAPI go?

1 Like

Thank you! WASAPI seems to have done the job :slight_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.