Chord Mojo isn't showing in Roon on iPhone

I have Chord Mojo connected directly to my iPhone via the Apple Lightning-USB (Camera)+Mojo USB cables. The device however does not show in Roon’s Settings–>Audio. I would expect it to appear under devices that are connected to iPhone directly. Mojo is turned on of course.

Please advise. Thanks!

There is no way for Roon to look through Apple’s audio stack / CCK dongle and see what’s on the other side. Just set the Mojo’s capabilities in the Device settings for your iPhone (PCM up to 768, DSD via DoP up to 256) and you should be fine.

2 Likes

Thanks, @RBM. I tried that yesterday. Two issues:

  1. I can not name the device. I click on the unnamed (iPhone) device and type in the name, say Mojo. When I click Return it’s not saved, and the device is still unnamed.

  2. Most importantly, I can’t SELECT the device. It does not show on the list of Zones.

  1. Try going into the Audio setup using a computer, add in the name to the zone, click on the black space. that should set the name

  2. Go into the audio setting and make sure Private Zone is OFF, it is on by default for phones.

I don’t see iPhone zone on the computer at all. (the Private Zone is - and was - set to OFF). I only see “Networked” zones and zones “Connected to this Mac”.

Btw, I have no problem with this setup generally. I can play Tidal (through its iOS app), youtube, etc. It’s Roon that I’m having issue with. It asks me to pick the zone before playing, which I can’t do obviously since it is not seeing the iPhone.

Also, side observation: I can not name or rename any of the Zones anymore for some reason. Doesn’t matter if I’m on the computer or the iPhone. I type in the text, hit enter, and whatever I typed disappears, leaving whatever text was there before or blank, if it was blank.

Problem Solved. Went to NAS and bounced Core. Everything is back and visible. Zones editable. I wonder if something got corrupted in Core.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.