Chord Mojo not automatically listed as audio zone when connected to Ubuntu Roon Server

Hello
I connected my Chord Mojo to an Ubuntu Roon Server. Whenever I turn the Mojo off and on again, the Core no longer lists it as an audio zone, so I have to go to Settings > Audio, where “device not found” is shown in red next to the Chord Mojo. I then have to click the gear and select Retry, after which the Mojo is found and can be used again as an audio zone. This is quite cumbersome. It didn’t happen when I was running Roon Server on a Windows installation, so I think it might have something to do with Linux using ALSA instead of ASIO. Is there any way to resolve or work around this?
Thanks!

I don’t think it has anything to do with ALSA. It probably has to do with the USB drivers. It does not seem to be auto connecting again.

I tested this again. When I’m in Settings > Audio and press the refresh button in the upper right hand corner (total refresh), it also reconnects to the Chord Mojo. So it seems Roon (Server?) just isn’t automatically refreshing the output devices/audio zones when clicking ‘Select an audio zone’. The behaviour seems different between Roon Server on Windows and on Ubuntu (since I’m running the Roon client on the same devices). Could this be some sort of bug?