Chromcast endpoint stops after a few minutes

Hi @support,

I have an issue using Chromecast as an end point.

The Chromecast works for a a few minutes, then it stops and is unable to be streamed to (sound stops, roon remote seek indicator stops). A reboot of the Roon fixes it only temporarily.

Other non-Chromcast endpoints continue to work without issue.

My setup is

Chromcast (Model 2)

  • Firmware: 1.42.172094
  • WiFi Network

Roon Core

  • IBM Intel i3 home server (TS140, SSD, 20GB RAM)
  • Ubuntu server 18.04.3 LTS (Linux 4.15.0-72-generic)
  • All files on local (spinning) disk.
  • Wired network
  • Roon v1.7 (Build 511) stable

Roon Remote

  • Macbook Pro
  • macOS 10.15.2
  • Roon v1.7 (Build 551) stable
  • WiFi Network
  • Also used iPad, with the same result.


Hi @stubaggs,

Apologies for the delay in getting back to you here, it appears we missed this thread, thanks for re-tagging us. As for the issue, I would try two things:

  1. Is the behavior the same if you temporarily use the Macbook to host the Roon Core? You can do so by making a Backup of your database and then in the Macbook Core go to Roon Settings -> General -> Disconnect. On the “Choose your Core” screen, select “Use this PC” instead of connecting to the Ubuntu server.

  2. Is there any change in behavior if you factory reset your Chromecast device?

Thanks, I’ll try a factory reset on the chrome cast first.

I’ll reply back o this thread with result.

1 Like

Reset of the Chromecast did not seem to help.

I also added a wired Chromecast Ultra, same issue.

I put a test playlist on repeat (which is a mix of file formats & sample rates, DSF, WAV, Flac, MP3, M4A). Noticed that the queue shows a number of tracks skipped (does not seem to be a pattern which ones). Roon/Chromecast seems to play a few tracks, then repeats the issue of getting stuck or skipping.

Running temporarily with macOS core (Roon v1.7 Build 511, macOS 10.15.2), I see the same issue.

Hi @stubaggs,

The next step here would be to take a look at diagnostics for when this issue occurs. Can I please ask that you note the exact local time + date + track that experiences this behavior and let me know here? Once I have this info I can enable diagnostics mode for your account.

@support Sorry for the delay, waiting for the weekend, Saturday night.

I started the playlist on Jan-18-20 18:00 local USA/Chicago time.

First skip happened at 18:16, track it skipped was 'What Wonderful World".

I then went back and selected this same track (just to convince myself the track is ok), it played fine when selected.


Hi @stubaggs,

Thanks for letting me know that timestamp. I have activated diagnostics mode for your account, and what this should do is automatically upload a log-set to our servers for analysis, but I’m not seeing any reports being generated.

Can I please ask that you use these instructions to send a manual set of logs? The best way to get them over would be Dropbox / Google Drive but if you don’t have either service just let me know and I can provide alternate upload locations.

Hi @support,

Here are the logs, let me know when you have them.

Hi @stubaggs,

Thanks for sending those logs over, I can confirm I received them, have found the error trace and I have requested feedback from QA regarding the trace.

To have all the relevant information on the case notes, can you also provide some information regarding your network setup? What model/manufacturer are you using for your router/switches/ect?

Once I hear back regarding analysis I’ll be sure to update you accordingly, thanks in advance for your patience here.


Thanks, networking setup is:

Main router/Access Point: ASUS RT-AC5300 - Running Asuswrt-Merlin firmware v384.14_2
Main networking hub, wired ethernet switch: TP-Link TL-SG1016D 16 port gigabit switch
Node wired ethernet switch: TRENDnet TEG-S8g 8 port gigabit switch.

Hi @stubaggs,

Thanks for the network setup info, am I correct in assuming that the Core is connected to the TRENDnet switch? Are both the TP-Link and TRENDnet swiches connected to the router or are you using daisy-chaining and have the Trendnet connected to TP-link?


Sorry for confusion! Tried two configurations, both exhibited the same symptom

Connections from Roon core perspective:
Roon Core–>TP-Link–>RT-AC5300–>WiFi chrome device
Roon Core–>TP-Link–>TRENDnet–>Wired chrome device

Connections from an internet perspective:
Cable modem–>RT-AC5300–>TP-Link–>Wired Roon Core
Cable modem–>RT-AC5300–>Wifi–>WiFi chrome device
Cable modem–>RT-AC5300–>TP-Link–>TRENDnet–>Wired chrome device

Thanks for the additional info @stubaggs, I have added it to the case notes.
Once I have the completed report from QA I will be sure to update you accordingly.

Hi @stubaggs,

I spoke to QA and we would like to enable some more advanced logging for your account. This advanced logging is very verbose, meaning that we should enable it, capture the information and then disable it fairly quickly. Would it be possible for us to schedule a time this week to do so? I will private message you so that we can work out a time to run this test.