Chromecast Audio not found - new Nest Wifi Network

Core Machine
ROON ROCK - Intel NUC - up to date

Network Details
Nest Wifi Mesh - 2 points

Audio Devices
Chromecast Audio

Description of Issue

I just moved and set up a new Nest Wifi mesh network. I plugged my NUC running ROCK into the router and all is good. I can access Roon just fine. However, I cannot see my Chromecast in the Audio settings page. “No audio devices found/manage devices”. I can stream to the Chromecast from other apps, I just can’t see it as an endpoint in Roon.

The first thing I would check is to make sure the Chromecast and RoonServer are on the same subnet. Using an app like Fling. See what the IP addresses are of the RoonServer and the Chromecast devices. The first 3 sets of numbers should match, if not, then they are on separate subnets. ( i.e. and is a match, and is not a match)

Thank you. Yes, everything is on 192.168.86.xx

Do I need to do any port forwarding?

Hi james,

FYI, not official support just a helpful fellow long time user. One thing to try as a test is to turn off the nest aux points and just run the central unit forcing the chromecast to connect to it and see if things work with just a single access point.

@Rugby that’s a great thought. Unfortunately, I just tried that out and same problem. Qobuz on my phone and laptop can see the Chromecast Audio but not Roon for some reason.

Well, the difference between your last network and this is, according to your first post, the Nest Mesh. What did you use before? Is this a gen 2 Nest?

Roon RAAT requires multicast routing to find endpoints. On Orbi meshes, Roon requires you disable IGMP proxying for example as to not interfere with this. Does your Nest have a similar option?

@Rugby Correct. I just moved into a new house and purchased a Nest Wifi network from BestBuy, so I assume it’s the newest model.

I don’t see anything about IGMP in the settings…and a web search doesn’t turn up anything, so I assume not?

Hopefully I can get my Ropieee out of the moving truck soon and see if it’s just a Chromecast thing.

Daft question but are you sure the Wi-fi points are all connected on the same network forming the mesh and any don’t need resetting?

James I have previously set up a couple of Google Wi-Fi devices for other people and there were no advanced network options available on the V1 devices at all.

Not helpful but I ended up buying an Orbi mesh system which has worked perfectly with a house full of Chromecast, Sonos and Roon devices

Hey @Michael_Harris this router does have some advanced settings such as DNS, DHCP/Static/PPPoe, LAN IP addresses, UPnP (on or off), IPv6 (on or off), DHCP IP Reservations, Port Management and Device Mode (NAT standard or Bridged)

James Sorry I didn’t consider those to be advanced, but the bog standard features.
If you don’t need UPnP I would turn it off, and generally you don’t need it.
It tends to be around advanced WiFi and settings, such as Beam forming, backhaul and Ethernet features like IGMP I was thinking of. Sorry I didn’t make that clear.

It’s been a few months since I’ve used Roon and I just realized that my computer and phone aren’t showing up in Roon either. The entire Audio screen is blank. I don’t see my laptop or phone both running Roon on there. I feel like they used to?

send a screen shot of your Settings-> Audio settings as mine have been turned off deliberately as I only use Streamers and Sonos. Also maybe try rebooting the Roon Core device

I have rebooted Roon Rock and reinstalled Roon and Roon Bridge on my laptop. iOS app is up to date

James something wrong there as it should at least find the local devices and anything else in your house it can see.
Before we tag support into this discussion, have your tried turning off your Firewall (completely disable it to see what happens then).

@Michael_Harris at a friend’s suggestion, i picked up a switch and put it between the Nest and the ROCK core. no luck.

I went back to square one, removed the Nest from the chain and put the Verizon Fios router back in the mix and plugged the Rock core directly into it and that seems to have solved it.

I was hoping to not rent the Fios router at 15/mo and use the Nest mesh network. I’d love to know if there’s a way to do that. I couldn’t find any firewall on/off settings on the Nest wifi

James I do not know enough about that setup to make recommendations beyond it’s not doing what it should be.
I assume to FIOS router is giving out DHCP addresses etc and maybe doin DNS (and obviously acting as a router).

Well that is exactly what the Google WiFi does as well, most of it automatic.
Sound like you have a bit of debugging to so around IP ranges etc.

You should be able to replace the rented router easily enough, I assume there is some kind of modem or Ethernet provided to that you can then plug the Google WiFi into and test connectivity.

If you then plug the switch into the lan port of the Google WiFi you should now have a working network and something to build on.

Maybe go with an Orbi setup, since many users have had success with them if you don’t want to rent the Fios router. You can always buy the FIOS router.

1 Like