Chromecast Audio not recognized

Hi - I’m in my trial period and a newbie. I have Roon up and running in my main system and I am trying to add Chromecast Audio in our garage. We have ample bars and Chromecast Audio it is showing on my Amazon eeros network. I’ve tried researching and the issue may be my Technicolor router. My system is

  1. Modem: Technicolor TC8717T
  2. Switch: Netgear 16-Port Gigabit Ethernet Unmanaged Switch (GS316)
  3. Router: Amazon EERO
    1. Software: v6.4.0-2092:
    2. Model #: J010011
  4. Roon Core runs on custom built PC with Windows 10 - 21H1 (64 bit & up to date)
  5. Roon version: 1.8 - build 831
  6. Chromecast Audio: tried both in garage (3 bars) and my desk next to eeros gateway (eeros attached directly to modem (4 bars)
  7. Model: RUX-J42
  8. FCCID: A4RRUX-J42
  9. IC: 10395A-RUXJ42
  10. CANICES-3 B/NMB-3 B

Quoting from a response I read to someone else from Roon: “We’ve seen that some Technicolor routers cause Roon to have difficulties communicating to networked endpoints. This can be resolved by adding exceptions for Roon and RAATServer to the router’s IPv6 firewall settings.”

I don’t have a clue on how to act on this guidance and, if this is my issue, I’m hoping you can guide me in layman’s terms.



Do the ChromeCasts work with other devices? Are they showing-up in the Google Home app and are they configured/setup there first?

Just to be sure. The Chromecast is not showing up in the audio setup in roon so you cannot enable it?

Hi - Chromecast Audio is not showing up in Roon.

I received another response last night from BlackJack who asked whether I was using Chromecast Audio and had set up a Chromecast account. The answer to both questions is yes (but I had been using Chromecast Audio in my garage with TuneIn Radio for many months and only just created the Chromecast Home account last night in response to BlackJack’s question.


As Roon and other apps use the same basic detection mechanism to find ChromeCast devices to play too, one would expect it to work in your place. So maybe there is something going on in your network like for example, the devices are not on the same network. Are the ChromeCasts visible from the machine your Roon Server runs on? You can also use the advice from the article below to check and troubleshoot your network setup:

Hey @Peter_Close,

It’s so great to see the community of our subscribers helping each other - thanks for posting about this.

I was wondering if, two weeks later, the situation with the Chromecast devices has changed at all? We’d love to help if there’s anything we can do :nerd_face:

Hi Rebeka - thanks for following up. Chromecast Audio is not showing up in Roon. I brought my device to my audio dealer today and he connected it to his Roon, so the device is not the issue. I’m also able to cast from my iPhone to the Chromecast Audio using TuneIn Radio. I’ve deleted the Google Home app from my iPhone and reinstalled it. Here’s where my Chromecast Audio path is now while I’m continuing to troubleshoot (reminder that Roon is up and running on my main system - same modem, wifi router (eeros), internet switch and core PC):

  1. Modem: Technicolor TC8717T

  2. Wifi Router: Amazon EERO (Gateway eero is ethernet hardwired, the other 2 are linked by wifi)

  3. Software: v6.4.0-2092:

  4. Model #: J010011

  5. Eero IPv6 is set to off

  6. DHCP & NAT is set as automatic (not set on Bridge)

  7. Switch: Netgear 16-Port Gigabit Ethernet Unmanaged Switch (GS316)

  8. Chromecast Audio: ethernet is hardwired via an UGREEN ethernet adapter connected to the internet switch connected in turn to the gateway (hardwired) eeros and then to the modem.

  9. Model: RUX-J42

  10. FCCID: A4RRUX-J42

  11. IC: 10395A-RUXJ42

  12. CANICES-3 B/NMB-3 B

  13. Roon: Trial period

  14. Roon Core runs on custom built PC with Windows 10 - 21H1 (64 bit & up to date)

  15. Roon version: 1.8 - build 831

Follow up from Roon’s Networking Best Practices guidance:

  1. Roon core is hard-wired via the internet switch
  2. Library is on a Synology NAS, hard-wired into internet switch
  3. Not using a guest network on the eero mesh wifi
  4. The guide mentions the Technicolor modem might be the issue due to its firewall (IPv6). I didn’t explore this as Roon is not blocked for my main system.
  5. Power cycling: I have recycled (turned off modem and eero, with Chromecast Audio hard-wired into internet switch).
  6. Simplify: I think I’ve done as much as I can but open to suggestions

I’d really love to get this figured out.


Hey @Peter_Close please accept our sincerest apologies for the delayed reply - it certainly was not our intention.

I appreciate you bringing us up to speed on the issue you’re experiencing and I’d be happy to point you in the right direction here. The next step that we would recommend is exactly what you had said - adding an exception for Roon and RAAT in the firewall.

To do this with Windows: Windows 10 Firewall Instructions

  • Right-click the Windows Start button and select Control Panel.
  • Click Windows Firewall.
  • Click Advanced Settings.
  • Click Inbound Rules, then New Rule.
  • Select Program from the Rule Type window, then click Next.
  • Click Browse below This program path to select the program executable file, then click Next.
  • Ensure Allow the connection is selected, then click Next.
  • Select When to apply the rule (Domain, Private, or Public), then click Next.
  • Enter a Name and optional Description, then click Finish.

You’ll want to add an exception for roon.exe and raatserver.exe, more information about this can be found here in our Help Center: Add Roon as a Firewall Exception

I hope this helps! Please let us know if this did not help - thank you! :pray:t3:


Chromecast Audio does work but I only use it in my garage hooked up to an amplifier and speakers using TuneIn Radio.

I’ve never set up Google Home. Because of your message, I just set it up and created an account and cast audio to my Chromecast Audio in the garage. It worked.

I then went to Roon and did not see Chromecast. I turned off Roon and then turned it back on and still do not see Chromecast.

I probably don’t need to say this, but Chromecast Audio is showing on my eero network as active.