Chromecast audio upsampling capability

Core Machine (Operating system/System info/Roon build number)

mac osx, running el capitan, core2duo, 2,93ghz roon 1.6 build 416
Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

chromecast audio ethernet,
Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

chromecast audio, toslink connection, AVR DENON X7200WA
Description Of Issue

I’m curently running roon 1.6 with a chromecast audio as a roon endpoint. Chromecast is connected to an AVR with toslink. When playing 24/96, everything is perfect and bitperfect. But when i’m trying to customize the roon upsampling dsp, the only choices I’v got is to choose beteween 44,1 and 48kHz. With the max PCM frequencies dsp option, all my recordings at 44,1 are upsampled to 96kHz, so I can say that upsampling is working. But it seem’s that i’m unable to bypass the internal “nominal” roon implemetation of chromecast audio by roon.
Is there a way to bypass this limitation? ideally i’d like to be abble to upsample 44,1kHz to 88,2 and 48khz to 96.
Thanks for your help!


In the dsp menu, instead of choosing PCM MAX, choose Custom and go from there

That’s the point, I can only choose between 44.1 and 48kHz in Custom upsampling. Roon let me the opportunity to upsample a 44.1 khz file into 48kHz, that’s all !

Hi @Sylvain_Murgier,

Can you share a screenshot of your DSP Sample Rate Conversion settings by using these instructions?

You should be able to do this by selecting “Custom” and then setting the 44.1kHz -> 48kHz like so:

– Noris

You’re not experiencing any dropouts? It’s been widely reported that the latest Chromecast Audio firmware (1.39.154182) has dropouts when playing 96/24 via Toslink. I’ve encountered this myself and have roon set to downsample everything to either 44.1 or 48.

+1 to the dropout issue, I’ve experienced it with 96/24 and adopt the same solution, everything downsampled to 44.1 or 48…

No dropouts in 24/96 using CCA, but i do it over ethernet, 'not wifi. Im using the chromecadt ultra power adapter which works very well with CCA.

Yes I can upsample from 44.1 to 48. But What I would like to do is upsample from 44.1 to 88.2 and 48 to 96. I just do not have the ability to do so because roon didnt offer me the right option in Custom settings menu. When I set upsampling to max pcm setting, all my files are upsample to 96. That’s why I do not understand why I cannot configure it manual !

Hi @Sylvain_Murgier,

You can do this by selecting the proper sample rate in the drop-down like so:

If you do not have these options available, can you please share a screenshot by using these instructions? I would also verify that your Chromecast Audio is up to date on the latest firmware.

– Noris

I know this is a year-old topic, but I just had the same issue while testing different chromecast audios for dropouts on toslink.

It seems that if a “new” chromecast audio is presented to Roon for enabling when already connected to toslink the upsampling capabilities will only be MAX (96khz) or custom, without the familiar Max PCM Rate (power of 2) option appearing.

However, if the same chromecast audio is disconnected, rebooted and connected to an analogic p2 audio connector and only then enabled on Roon, the option for power of 2 will present itself as viable, and will be retained if the input is changed to optical again afterwards.

Posting this because I found very interesting how the puck reports its capabilities depending on what/how it is connected to it and how it affects Roon capabilities on its end. Hope this little experiment can be useful to anyone.

1 Like

Thank you very much - thought I was going mad!

I guess the Room team should resolve this somehow?

1 Like

Mike, regardless of how the Roon team may deal with it, why don/t you try to reset the chromecast to factory settings and set it up while connected to a standard headphone plug (p2)?

After setting it up the option for power of 2 will be available and you can just switch again to toslink. The option will still be there if my case can be reproduced. Maybe this workaround can suit you :wink:

1 Like

Hi @Marcelo_Bulgueroni / @Mike_Gregory.

Is this behavior reproducible each time? Can either of you please reproduce this issue, note the exact local time + date you see both options and then only see one of the options and provide screenshots of the issue?

Hi Noris, I tested two times before, but I will try with a spare chromecast I have around here. Probably in the weekend and will post here the details.


Yes I followed your suggestion and this workaround worked fine! Thanks again

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.