Chromecast built-in pausing, Primare NP5

Core Machine (Operating system/System info/Roon build number)

Roon ROCK with latest build (521).

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet connection to a switch connected to an AImesh-nod running wifi connection to an Asus RT-AC86U with AsusWRT-Merlin.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Primare NP5, coaxial connection to a Primare NP30.

Description Of Issue

Hello!

I am having a strange problem with Chromecast built-in on my Primare NP5. From time to time the playback stops from nowhere. The play/pause button in Roon shows that it is playing, but the Google home bar shows that it is paused. The only way to play a track is to choose another one in Roon. It seems that it is some kind of conflict between Google home and Roon. Anyway, it would be great to get some advice on how to fix this problem.

I have a Roon ready device connected to the same switch and it is working as it should, so the network is fine.

Thanks!

Hello @jazMirti,

If playback in Roon is continuing to the device, it is likely that the NP5 is failing to communicate that playback has stopped to Roon. We do not have any visibility into the device besides for what the Chromecast API is telling us. Therefore it’s unlikely there is anything we can do to fix this behavior.

I recommend you reach out to the Primare support team as they would be in the best position to diagnose what’s going on here.

-John

Hello!

Thanks for the answer. However, the NP5 is stopping playback without me giving any commands for it to do so. If I understand you right the problem might be with the NP5, that the playback is interrupted somehow and that the NP5 can not tell Roon that the music has stopped?

The thing I fail to understand is why the NP5 can communicate with Google home that the playback has stopped even though I have not given the command.

Thanks!

Same problem I have in my setup with NP5 and Roon over Chromecast combination. Annoying… Any suggestions?- appreciate help

No software update available?

No software update yet. They have promised Roon ready certification by the end of marsch though.

It seems, problem resolved with the firmware 1.4 update.

Guys,

Did this get the Roon Ready update?

No update yet.

Thanks @jazMirti. I presume they won’t take a turn on this? You’d think they have some sort of strong commitment looking at the press releases.

Do you like yours? It would be replacing a Chromecast Audio which is actually OK, just drops out every so often.

I waited an age for Bose to release AirPlay 2 on the soundtouch stuff we have through the house, until I actually thought they were never going to do it.

They have made so many promises that have not come through. I gave up on the NP5, sold it and went for a RPI solution instead. Never again will I buy a product with the promise of “future updates”. It is sad really, because Primare produce really good sounding amps. The Prisma module is a disappointment though.

1 Like

Thanks for the info. Maybe there’s a reason they don’t seem so popular. As you’ve pointed our, their hardware is normally beautifully made, but maybe they just can’t manage the SW side of things too well.

1 Like

Yes, I’m one more customer waiting and waiting and nothing…and like you said, these guys are struggling with the SW side of things, I’m also having all kinds of problems with the Airplay 2 implementation, it’s really buggy…lose connection, AppleTV sound doesn’t came out, etc… :frowning:

1 Like

Hey @Renato_Semedo

I actually spoke to one of the guys at Primare the other day & he was really straight with me in admitting the issues they’ve ran in to. I actually spoke to somebody else who thinks partly some of these issues are down to a Google Home updates/s. It gave me a lot more confidence this may be fixed very soon. The info I got led to updates being rolled out through September, with a full rebuild of Prisma. I also gather bit-perfect playback is right around the corner.

1 Like

Ho man I hope you’re right…it has been painful… :crossed_fingers:

1 Like

I guess it’s just a case of sign up to their mailing list & hope for the best!

They really did sound confident, so hopefully they’ve got it nailed this time around.

I’ve also had and still have issues similar to yours. Bought the SM35 streaming module in May. At first music stumbled now and then. A very small, subtle skip in the music. Sometimes 10 skips in a song, sometimes once every 30 minutes.
Lately I’ve had problems starting songs. Some albums have almost impossible to play. I could click through entire albums and no song would play. Tom Petty Wildflowers and the Rest and The Dirty Knobs being among the worst. On Friday Terry Medalen of Primare guided through troubleshooting and resetting up my PRE35. It worked for hours and I thought the troubles were gone. After more hours of playing on Saturday it suddenly reappeared. This time most Bruce Springsteen but no problem with Petty or Knobs. Airplay works very well but the SQ is inferior. Going USB, then bypassing SM 35 also works very well. But again, slightly inferior SQ. Frustrated and wondering why I bought the SM 35.

Just now after playing music for a couple of hours I had a hard time getting anything to play. Tried 10 different albums, couple of songs on each. Nothing till I picked a local file. Playing. Always Tidal never local files give these issues. Casting from Tidal works, just with Roon there are problems.

https://primare.net/information/network/roon-ready/?fbclid=IwAR0AsL5L8S6cfFi-35f6O9l1ZPiVRF0mHMDQJa3ck6asqOeDXY4AZ2lVDlY&v=06fa567b72d7