Chromecast Display Stopped Working

Core Machine (Operating system/System info/Roon build number)

Mac Mini OsX 10.14.5 Roon 1.6 build 416

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Devialet via ethernet

Description Of Issue

I have been using the display feature for more than a year without any problem. I use a NVidia Shield with Integrated Chromecast connected to my TV via HDMI to display information. Starting this morning, when I play music, everything works perfectly except the display which keeps displaying “Roon” as it usually does when it starts, but it does not go beyond that and eventually aborts. I have restarted and disabled/enabled pretty much everything in the process without any success. I have not updated anything anywhere recently except for the Shield TV, but it was more than a week ago and display worked perfectly after the update.

I have also not been able to locate any post discussing the same symptoms, so I am out of ideas here! Any input would be welcome.

Hi @Michel_Guillet,

Can you please let me know more information regarding your network setup? What is the model/manufacturer of your router any any switches/range extenders/powerline adapter/etc?

Are you able to still access Roon Displays through other devices on your network, such as a web browser not on the Core machine?

I can access the Display in my browser on my laptop without any problem. I can cast from my phone to the Shield TV using other apps.

The Roon Server computer is connecting to the network via wifi, while the Shield is using ethernet. I have tried switching it to wifi, but still the same issue.

The router is Asus RT-AC68U with Merlin firmware. There is a switch on the network.

Hi @Michel_Guillet,

Is there any change in behavior if you connect both the Core and the Shield to the router, temporarily bypassing the switch?

What type of browser are you using to display the Roon information on the Shield? Is the behavior the same if you try using both Chrome and Firefox (if they are supported apps)?

Hi noris,

I did try to bypass the switch without any success.

However, out of the blue, the display feature started working again yesterday morning… Nothing I can think of that changed in-between: automatic updates are disabled on all devices, no restart or reset, no change in options.

I am suspecting the issue comes from the Chromecast implementation in the Nvidia shield, as it has been less than stable recently and I have read many complaints about it.

1 Like

Hi @Michel_Guillet,

Glad to hear your Nvidia Shiel is up and running again. Strange that this issue occurred and was resolved with no changes on your end.

If the issue occurs again do let us know and we can take another look, I will close out this thread for the time being.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.