Chromecasts have gone missing

Core Machine (Operating system/System info/Roon build number)

custom windows PC

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Core connected by ethernet to router. Everything else connected through wifi with Plume wifi.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Google chromecasts connected to various audio sources.

Description Of Issue

I have about 7 different chromecast audio devices in my home. Everything has worked great through Roon for some time. But now, roon only sees 1 device. They’re all connected the same way (wifi). Chromecast works well using other apps (Qobuz, podcasts, etc). Where have my chromecast endpoints gone?

Have tried restarting the server, which doesn’t make a difference.

Hi @Avi_Zevin,

Can you please share a screenshot of your Roon Settings -> Audio tab?
Is there any change in behavior if you try to reboot your networking gear as well?

Hi @Avi_Zevin,

Are your Chromecasts grouped via the Google Home app?
I would try un-grouping there if so and see if they appear individually after.

I do have groups set up so I can play, e.g., through all devices upstairs at once in addition to indvidually. But this has never been an issue before. I’ve deleted all the groups in order to test this and now the only thing different is the two “Google Cast Group” options in “Other Network Devices” are missing.

A post was split to a new topic: Chromecasts gone missing?

Hi @Avi_Zevin,

What model Chromecasts do you have? I have two Chromecast zones on my end - an Ultra and a TV Built-in and both are working as expected for me.

Since you are using a Windows PC, I wonder if the Roon update caused an issue with your Windows Firewall settings, I would check this:

I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

I have 3 chromecast audios, 2 chromecast v2, 1 vizio soundbar with chromecast built in, and various types of google homes and 1 google home display. Only one of the chromecast audios appears. All other devices are absent.

I actually had forgotten that the one device that continues to work is the one that’s connected via ethernet, not via WiFi. Does that help diagnose anything?

I’ve checked the windows firewall settings and that doesn’t seem to be the issue. I even turned off windows firewall completely temporarily to test it with no difference made.

Is it possible that your WiFi is now using a different IP address range to that set on your ethernet? Roon requires that all devices are in the same subnet address space.

If your router or WiFi has an IGMP snooping feature turn it off if it’s on as I found after the previous update that Roon stopped seeing my Chromecasts. I think something’s changed in relation to multicast discovery in Roon but obviously can’t be sure. I hadn’t changed my network setup at all. It had always had IGMP snooping on and worked fine but then with this update nothing showed until I turned off IGMP snopping. Google Home and BubbleUPnP could see them fine though with it on or off. Go figure.

Thanks for the suggestion. I checked and everything is still on the same subnet.

Hi @Avi_Zevin,

Yes, this is an interesting clue. If you put the PC on the same WiFi network as the Chromecasts, do they then appear? Seems like you might have some kind of VLAN set up.

Yup, this appears to be the issue. I use Plume and they apparently made some change, but I figured out how to get the devices to appear back in Roon.

Thanks for help troubleshooting.

You might want to say how this was resolved, so that the Support team can make a note of it for future reference? Thanks.

Plume has a feature called HomePass, where you can set different wifi permissions on the same network name using a different wifi password. There is a way to share access across these HomePass groups. My Chromecasts were on a separate HomePass groups for security reasons from my Roon core. That worked fine for the past months. But Plume may have made some changes (working with them now) that limits access across groups. So by putting the Chromecasts back on the same group as Core, the devices appeared in Roon once again.


Hi @Avi_Zevin,

Thanks for letting us know that HomePass was the issue here and that you’re working with Plume to troubleshoot this further! Do let us know if you run into any other Roon issues!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.