Chromecasts not showing up

Core Machine (Operating system/System info/Roon build number)

Rock, latest build

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Unifi router, switches and aps

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Chromecast devices

Description Of Issue

TEXT GOES HERE
@suppory Since updating to latest RoonOs I am having issues with Chromecast zones not showing up. Nothing has changed network wise, just got a brand new device today and it didn’t see it, I rebooted core and now its lost all of the them. Wired or wireless. They have worked faultlessly up until today. They all show up in Google Home and all other apps.

Had to reset Google Home to get them back. No idea what happend but I noticed in the home app none of my Chromecast groups showed up might have been related. But a reset seems to have sorted it.

Sorry but this is happening again. It’s refusing to show one of my Chromecasts. It showed up yesterday before I did the update now it’s gone. It shows up in Google Home, Tidal, Spotify , Qobuz even Bubble UPnP sees it but Roon refuses to. Any ideas @support.

After another reboot of the core no Chromecasts show up at all again. Restarted my entire network still nothing. Why isn’t Roon seeing them nothings changed in my network config so this makes no sense as everything else on my network can see them apart from Roon and they all worked until I installed the latest updates to Roon and ROCK.

I had my Chromecast go in to an odd state with Google home and roon as you have. They came back into home but not roon then one day they showed again.
No idea why.

Hello @Simon_Arnold3, a reboot is definitely a first good step for the second one could you temporarily disable your firewall and antivirus and see if this allows the devices to be seen? I am running 571 at the moment and both of my chromecast devices are behaving as expected.

I am sure its Googles end but some clarification would be good. Infuriating never had this issue before. They have always showed up and worked flawlessly.

I don’t have any software firewalls or antivirus it’s on ROCK and as I have said nothings changed in my setup at all other than Roon and ROCK updates and I already restarted everything and nothing now shows up for Chromecasts and I have 5. All show up in all other applications and Google Home and work as they should that way. Just Roon won’t see them. And it’s always worked up until now.

3 have now shown up but two still missing in action.

Enabling the ones that show up seems very sluggish its not instant like my Roon bridges or other RAAT endpoints. It takes quite a few seconds to update. This is new and not been like this before. Possibly related ?

well after phaffing around a lot got them all back for now. Will see what happens with it tomorrow.

And I turn on off and back on again later and it wont find it. This is very tiresome.

And it returns to Roon after doing nothing just leaving it on for about 20mins after turning device on.

Hello @Simon_Arnold3, thanks again for your report. I’m going to enable diagnostics for your account and reach out to the team regarding this issue. Thanks for your patience in the meantime and I’ll be in touch once I have spoken with our QA team.

Hey @Simon_Arnold3, can you also tell me what model chromecasts you’re using? Thanks!

I have a Chromecast Audio, Shield Android TV box, Naim Atom, Sony TV and the recent addition is a JB Link 20. The latter is not on all the time as it’s battery powered but has issues with it taking an age to show up in Roon where elsewhere it’s available as soon as its powered on fully. The others do take a long time too of they have been powered off. They do all appear eventually but as to how long seems very random.

Ok after some advice from forums related to my network gear. I turned off igmp snooping. It now discovers them instantly. Odd as this has always been on and worked before and has no issues in Google Home or BubbleUPnP. It is one setting recommended by the manufacturer to use for Chromecast devices to, it seems though that Roon doesn’t play ball with it. Maybe this new device I bought is the culprit and it’s causing issues? Any way for the time being it’s sorted it. Will do some more digging to find out more though.

1 Like

I think it’s in this sentence where the snooper doesn’t know when something does or doesn’t.

" may be filtered from the links which do not need them, conserving bandwidth on those links."

https://routerguide.net/enable-igmp-snooping-on-or-off/

Maybe it’s odd as it’s recommended to use it with Chromecasts on a network.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.