Chromecasts were working, now they're not

Core Machine (Operating system/System info/Roon build number)

Qnap ts-873. Qts 4.4.1. Latest stable build of Roon 1.7.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Asus router. Wired core. Chromecasts on WiFi.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

Suddenly my chromecasts are not detected by Roon. I tried rebooting every device and service involved including the router. They worked before. I’m not sure what changed. Any idea on how to fix? The Chromecasts work fine on their own.

Hi @J_B,

Have their been any changes to your setup around the time that this started occurring?

Do you have any Windows or Mac remote devices that you can temporarily use as your Core machine? In this configuration are you able to see the Chromecasts?

This happens to me from time to time and usually restarting Roon takes care of it. Once or twice I had to setup Chromcast Audio from scratch.

Hi sorry I didn’t get back to you right away, it’s been a busy couple of weeks.

As far as I know I didn’t make any changes to the set-up.

I tried an old server which has an older version of Roon (1.7 505) and it can see the Chromecasts. So maybe it’s the newer version’s problem? (build 511)

Hi @J_B,

Where was this old server located and how is it connected compared to the QNAP? I don’t think this is due to the version, but we can perform a test here on the working PC:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” / “RoonServer”
  • Rename the “Roon” folder to “Roon_old” or “RoonServer” to “RoonServer_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder on build 511
  • Verify if the Chromecasts are still visible on the 511 build on the PC that was previously working
  • (Optional) Rename the new Roon folder to “Roon_updated” and the “Roon_old” folder back to Roon to get your old build 505 database back

I upgraded the old server to 511 and the Chromecasts are visible so it’s not a problem with the build.

Regarding the network connections. Both servers are connected to the same wired switch (no wifi involved).

Thanks for confirming @J_B. It sounds like this behavior only impacts the QNAP in this case, so we need to take a closer look at this aspect. Do you have any firewalls on the QNAP that you recently set? I would also make sure that Open vSwitch is not turned on in the QNAP as this setting has caused issues in the past.

I don’t have any extra firewalls or anything like that. Also, there is no vswitch (virtual switch?) activated.

Hi @J_B,

Can you please share a screenshot of your Roon Settings -> Audio tab when using the QNAP to host the Core?

What does the IP Address of the QNAP/Chromecast look like? Can you check to see if they are on the same subnet in your router DHCP listing?

I’ve attached screenshots.

The NAS is on (static local IP but assigned by router).

and the Chromecasts are (dynamic):

Hi @J_B,

Thanks for sharing those screenshots. Roon does appear to pick up on other devices so this goes against the firewall theory I had.

Have you by any chance tried to reinstall the Roon App on your QNAP yet? I would try making a Backup of your Roon database and then setting the Roon database location to elsewhere via the QNAP Web Interface to start off with a fresh database.

I would verify if a fresh database exhibits the same behavior before restoring the backup. Can you give that a try?

Ok, I tried that, backed up, changed the location of the DB, removed the app. Re-installed and it’s still not showing the Chromecasts.

Hi @J_B,

Can you please provide a set of logs from the QNAP next? You can access them by using these instructions (bottom of page), and afterwards you can upload the logs to Dropbox / Google Drive and post a link here.


Hi @J_B,

Thanks for sending those logs over. I looked through them and I’m not seeing Chromecasts listed at all in them, so there’s not much info there unfortunately…

Have you by any chance tried to factory reset one of the Chromecast units that are not showing up yet? That might be a worthwhile troubleshooting step.

Hmm, I’m not quite sure how to do that but I guess I could look it up. They do work for other apps and devices though… I’ll try it when I get a chance sometime this week.

Oh thanks!

1 Like

I’ve had Chromecasts mysteriously disappear and reappear. Remember to clear them out of Google home as part of the clear out.

Ok, I did the factory reset. No change.