Clash of ports with roon-http-api

Hello @spockfish ,

I’ve just added a 7" screen to my main Pi with DAC and tried Ropieee. It works like a charm. Many thanks for your efforts!


I’ve noticed that your Roon extension is a fork of roon-http-api by Bastian Ramelan.

I already had this extension installed and running for another project of mine (IR remote in another room), and your extension uses the same TCP port (3001).

I’ve changed the port used by roon-http-api and my script and all went back to normal, Ropieee worked and my stuff worked.

It could be a good idea for you to use a different port by default for your extension.

Hi @Nicolas_Will,

I’m not sure what you mean. My extension is certainly not a fork of roon-http-api.
It is indeed using port 3001, so yeah that causes problems.

However, I’m about to release a RoPieee update that has a completely rewritten extension which does not use HTTP anymore, hence this problem goes away very soon.


My bad, then, about roon-http-api! I had seen a version of it on your github repo, and I assumed… Sorry!

I’ve solved the TCP/3001 clash by modifying my other extension, so nothing horrible happened.

It may be a good idea for Roon to track/manage the ports used by the extension, in general, though.

Thanks for the reply!