Clashing backups?

Hi - I’m in the process of transitioning from JRiver to Roon, and have a set-up that was originally optimised for JRiver - which causes some odd side-effects. My current issue is caused (I think) because I keep the originals of all my music files on a dedicated hard drive on my computer in my office, (where I can optimise all the metadata easily, mostly using Jaikoz); which is then automatically synchronised to two NAS’s - one physically connected to my music system, but connected to my home network wirelessly; and one simply for backups. After all, as more and more of my files are hi-rez downloads for which I have no physical media, two backups is the minimum safe number, don’t you think?

My issue (finally), is that, whereas my updates to the music NAS used to only involve any files I had purchased or updated since the last sync, now it seems to always involve more than 50% of the files - around 1.2Tb. Which at 4.5Mbs a second is well over a day a time. Presumably this is because Roon updates the files, so every time my sync software runs a comparison, all the files Roon has updated show as unmatched to my master copy?

Before I start reworking my system, is that likely to be the problem?

Er, no - Roon does not modify your music files in any way; it only reads them. Something else must be going on.

I ran both on the same pc

A file changed anywhere anyhow will be seen by the FileWatcher process as a changed file and will trigger Roon AND JRiver to reimport.

If it’s changed in JRiver obviously it doesn’t have to

But Roon will re import and reevaluate if I have it right. Quite often you will see an unidentifiable album become identified as you make the correction elsewhere - I run on 2 screens

Unless you are making big global changes in JRiver involving massive numbers of filesI don’t see how the sync should be so big

I stand corrected but I believe Roon does not write to your files. JRiver will if tags are flagged to write to the file

My process is to change tags on my main PC then sync to external USB dives for BU 2 off them. Mostly my syncs are 20 - 30 g at most


Hi @Graham_Thorburn1 ---- Thank you for the report and sharing your feedback with us. Very appreciated!

Just wanted to touch base and see how things are going. If further assistance is required, please drop a flag for support (i.e @support) and a member of the team will be glad to help.


Problem not yet solved. As I’ve got further into troubleshooting, it now appears to be a problem with all attempts to copy, and involves FileCopyEx issues. The hunt to identify the real problem continues!

Apparent solution - though I don’t understand it. I uninstalled Google Backup and Sync, and all appears to be well.

I use an app called SyncBack this works like a charm


Thanks Mike. I currently use FreeFileSync, which (mostly) works well. But I may give SyncBack a try.