Classical album cataloging is not correct

Roon Core Machine

Roon Nucleus

Networking Gear & Setup Details

Roon control is on PC running win10.
PC connected to router via wi-fi.
Router hardwire connected to Nucleus via rg6 cable

Connected Audio Devices

Samsung 2TB external SSD> Nucleus via usb> Audio GD R8 DAC via usb out of Nucleus> Emotiva RMC-1L from Audio GD XLR out to XLR in

Number of Tracks in Library

1944 of 2061 albums identified
I could not find the # of tracks listed. Assuming 10 tracks/album about 20K tracks.

Description of Issue

Classical albums are not being cataloged correctly. This is my Beethoven albums on the ext SSD

I would like to show you what is in my library and what shows up in ‘Beethoven’ either artist or composer, in Roon but I apparently don’t know how to copy a screen capture and pin it.
Suffice it to say only half of what is on the ssd is being listed in Roon.
This is happening in all my classical composers, not just Beethoven.
Pretty sure this is a new problem. I noticed it when I went to do some listening to music on a new DAC. I use Beethoven’s 9th as a test when evaluating dac’s and ttheir different filters. This time none of his symphonies showed up under either artist or composer.
Roon seems to have changed how it categorizes classical music. And it’s broken. Please fix.

@Thomas_Giloy - now that you’ve opened this new support thread, I will close the thread that you started on this issue yesterday. Let’s keep everything in one place.

1 Like

The number of tracks in your library is given on Roon’s Home page; for example:


of tracks is 28,047.

The first screenshot is the albums on the usb attached ssd I have in my Beethoven folder. There are other Beethoven tracks on compilation classical albums. Some of those albums show up on the second screenshot, but most of his symphonies on the ssd do not appear on Beethoven’s artist or composer page. The 12 albums you see are all that show up under overview on both his artist and composer pages.
Mozart, Bach, etc. show the same problem. Many of the symphonies they composed are missing, but albums that may have a piece by the composer do show up. And a few odd things show up. Like in Bach Jethro Tull Aqualung and living in the Past albums are listed.

Bottom line is the cataloging of classical files is not working in Roon.
If you need anything more please let me know. Or if you have suggestions for a fix.

1 Like

My guess is that your Roon database has got thoroughly scrambled somehow. Best to wait until someone in the Support team can respond (will be after the weekend at the earliest).

In the meantime, I would like to try re-scanning my entire library to see if that would fix the problem.
I know how to re-scan an individual album, but I cannot find how to re-scan the entire library and start from scratch. ‘Search’ has no instructions on how to do a total re-scan.
Could you point me to instructions for doing this.

Also, is there a way to force another download of the latest firmware in case it was somehow corrupted during download?

Look for “rescan” in this article:

Also, is there a way to force another download of the latest firmware in case it was somehow corrupted during download?

Do you mean reinstall the Roon OS and Roon Server? If so, see here:

1 Like

A week later and the problem persists.
I’m still waiting to hear from the ‘Support Team’.

Hey @Thomas_Giloy,

Thanks a whole lot for following up on your initial post — sorry we’ve missed on this thread for so long… we’d love to help out.

For the album you’re referring to in this example (Beethoven Symphony No.9 - Hi-Rez -SACD) that does not show up under Beethoven’s artist or composer page, does it show up in Roon if you use the search function or if you simply find it under My Albums?

If I search ‘9th’ I get nothing. If I search ‘9th symphony’ it shows (with a lot of other symphonies not necessarily Beethoven or 9th).

It does show up under ‘albums’ along with the other missing albums.

If I search ‘Beethoven’ all his works show up including all his symphonies.

If I use the hamburger drop down menu and select ‘artist’ and choose Beethoven it does not show all his works.

If I choose ‘composers’ the same incomplete list shows.

On either of those pages if I select ‘compositions’ a more complete list (seems to be the complete list, but haven’t checked).

Shouldn’t everything show up under both artists and composers?

I was hoping to hear something from you by now. Am I the only person this is happening to? Is there a fix? Is this a system wide ROON problem that you are working on? Or are you just blowing me off?

I have noted that if a composer appears in two tags, then the work does not show up in Composed By.

There are other issues with Composed By not working as expected.

So does that mean that this is a known problem and Roon is working on a fix ??

Hi @Thomas_Giloy,

Can you please post a screenshot of the album page for one of the Beethoven albums that isn’t showing up on your Beethoven composer page? Then, please tell us if you are preferring your file tags, or Roon’s, for that album. Thanks!

I have constant issues with classical metadata; OP is not alone in this. it’s so pervasive that’s almost impossible to capture in a single support thread.

classical is deeply, deeply broken in Roon.

Apparently I’m not preferring either, although according to my import settings there should be a preference. Pardon the multiple ss’s, but thought they may help.

1 Like

Is this problem going to be fixed??

Hi @Thomas_Giloy,

Thank you for the screenshot, those are helpful and much appreciated. Check the metadata for this album to see if Beethoven is incorrectly cited as Primary Artist, in addition to Composer. If so, remove Beethoven as Primary Artist and the album will show up under his Composer view. Thanks!