Classical Composer Confusion

I am finding it difficult to find some of my classical collection in Roon. When I rip CD’s I tag my classical music by composer last name, and in some cases I include initials to avoid confusion (e.g. Bach, Strauss, etc.). I have roughly 30 albums tagged with the composer as Bach, J.S. Roon shows me only two albums tagged in this way and the rest show up under Johann Sebastian Bach. Why is this and how to fix so I can see all my Bach music in one search?

Secondly, if I look at Composers it shows me 87 compositions under Johann Sebastian Bach. I can then sort those in various ways. But what I would like to see are all 30 of my Bach Albums, and nothing else. Is there a way to do this?

Hard to say without more information. I’d recommend reading room’s Tagging Best Practices KB article:

Here’s a screenshot of my music that is tagged as “Bach, J.S.” for composer as suggested by the folder where they reside on my NAS. Searching “Bach” via Roon yields several categories: Artists, Performers, Artists, Composers. Clicking on Composers gives me Johann Sebastian Bach, Bach J.S. and some others that are not related. Clicking on Bach, J.S. shows me only the two albums that I have circled in the screenshot. Clicking Johann Sebastian Bach gives me only 3 of the others as ‘Main Albums’ and two under ‘Production’. This is all very confusing, I expect to see all of the albums in the screenshot.

Reading in the link you provided, according to Roon’s way of cataloging::

You’ll get much better results if you stick with the likes of the following:
Wolfgang Amadeus Mozart
than if you use:
Mozart, Wolfgang Amadeus

I’m banging me head!!! Classical composer= last name first!! There’s even an option for it in settings. I have done it this for way reasons other than Roon.

If you inspect your “Bach, J.S” albums with a tag editor (MP3Tag, Foobar for ex.), do all tracks have COMPOSER tag set to the same value “Bach, J.S.” ? This really matters. You could then go to the Roon Composer view and merge composers “Bach, J.S.” with “Johann Sebastian Bach”.

Yes, I verified in mp3tag all of my albums in question are set to composer as “Bach, J.S.”. I’ll have to look into merging as you suggested. Hope I do t have to do so to my entire collection, we’ll see.

I have looked at merging the composers to no avail. When I select ‘Composer’ view from the main menu there is only Johann Sebastian Bach available. I also went into the library settings and set the Composer Credits to ‘Prefer File’ but that didn;t change it either.