Clicking and Popping before a track plays - sometimes

Roon Core Machine

Rock on NUC 10

Networking Gear & Setup Details

Ethernet - no VPN

Connected Audio Devices

HIFiBerry Dac+

Number of Tracks in Library

286,713

Description of Issue

Just before a track plays - but not always - a click or pop plays - sometimes loud, sometimes soft, sometimes out of just one speaker, sometimes in stereo, sometimes not at all. This could happen as a playlist is progressing - or as I skip songs manually. It does not seem to happen with Tidal songs. I’ve tried adjusting the device settings - MQA capabilities, resynch delay, max sample rate, max bits per sample, enable MQA decoder - nothing seems to work.

Check for sample rate and/or bit depth changes when that happens - most likely it’s due to that, and that‘s usually a DAC related issue without remedy other than resampling all content in Roon Muse settings to the same rate/depth.

1 Like

Where sample rate and/or bit depth changes the “pop” can be fixed in many cases by increasing “Resync Delay”… I believe the device has to be Roon Ready for this parameter to appear.

1 Like

I’ve set that all the way up to 10,000 - still pops.

Have you tried restarting the server (core) after setting resync ….it might help…

1 Like

I had allo gigi one signatures (rasberry pi) (2 of them) Both popped and clicked. Annoying. Went to ifi Zen Stream. No longer ever get a pop. Completely eliminated and only changed the one thing.

2 Likes

Very strange, resync pretty much fixed things for me. Looks like a compatibility problem somewhere….

1 Like

Set resync delay to 10,000 (the max) and restarted the Roon server. Started a playlist, and “BANG.” A loud one. This happened not after the “resync delay” wait before the song started, but as soon as I pressed “play.” (Then the wait - of course - I had set resync delay to 10,000 after all.) A few tracks later a soft pop (with the delay after). Now I’m finding it difficult to get a pop at all. Strange. But my bet is that the clicks and pops will eventually return (hope I’m wrong.)

Well, I was right (darn!). Just got a small pop - this time just before the music started (not before a delay).

Have you got another endpoint or DAC hat to try?

:innocent:

1 Like

I do. So far no clicking or popping on the alternate I’m now testing. (I have 7 other endpoints.)

Possible issue with the HiFiBerry DAC hat? :man_shrugging:

Which RPi version do you use with it?

1 Like

Raspberry Pi 4 Model B 8GB

HiFiBerry DAC2 HD

I’ve asked Hifiberry for support too. I’ll give our complete conversation here, but in the end they recommend that I “try to resample to a fixed sample rate in Roon… …check the DSP settings in Roon.” How do I do that?

Here’s the conversation:

Question: Please see my post at https://support.hifiberry.com/hc/en-us/community/posts/360012737077-DAC2-HD-Clicks-and-pops-between-tracks?page=1#community_comment_13477805911325

Here’s the Roon support link: https://community.roonlabs.com/t/clicking-and-popping-before-a-track-plays-sometimes/

My DAC2 HD is a “hat” for my Raspberry Pi 4 Model B 8GB.

Answer:

Hi,

Slight pops - especially when changing sample rates - are normal. Depending on the amplifier these might be noticeable or not. You can try to resample to a fixed sample rate in Roon.

Best regards,
Daniel

My reply:

Pops can be quite loud - more than “slight.” Which amplifiers have pops that are less noticeable? I have 8 different endpoints - most Hifiberry - and this is the only one doing this. How do you set a fixed sample rate in Roon?

Hifiberry Response:

Hi,

We run several amplifiers here, Yamaha but also some PA devices. For the fixed sample rate, check the DSP settings in Roon.

Best regards,
Daniel

Well, what HiFiBerry have come back with is correct.

You have the choice to upsample within Roon DSP settings for your endpoints.

This guide can help

Nice technical article. How do I get to MUSE and what do I turn on or off?

taken from the page of the link before your post…

1 Like

I can’t take credit :sob:

Thank you for directions to MUSE. Here’s what I have now - what should I change?

read around Roon’s help center articles, as i.e.here.
Turn on sample rate conversion and set all incoming rates to output the same max output rate of your DAC, as like 192kHz.

EDIT:
you’ve got to use a tablet, Windows PC or Mac to see all settings!
Mobiles don’t show all there is!

This is the default, which I’ve now turned on. If this works “as is,” great. If not, which of these things should I try changing first?