Clicking noises/pops with Pro-Ject DAC Box DS2 ultra

I’m using the roon tested Pro-Ject DAC Box DS2 ultra with Firmware v1.10. The DAC is connected to an Intel NUC NUC7i7DNHE in a fanless Akasa case with an 1TB SSD using an Oehlbach USB Plus B 100 cable. I have a Beyerdynamic a20 hedaphone amp directly connected to the DAC and when I listen over headphones (Beyerdynamic T1 (2nd generation) or Sennheiser HD 600) I get occasional clicking noises/pops on some tracks. This is mainly the case with quieter parts of classical music. The files are always FLAC files ranging from 44.1 kHz to 192 kHz and 16 to 24 bit, stored on the internal SSD or a QNAP Nas, which is connected to the NUC via LAN.

Hi @MartinD,

Can you confirm whether or not these noises occur for other endpoints? Is it only limited to the Pro-Ject?

If it’s limited to just the Pro-Ject DAC, there are a couple of things we can try to narrow down where this behavior is stemming from:

  • Try a different USB cable with the DAC
  • Try using the DAC without the headphone amp — does the same noise occur?

Hi Dylan,

this is limited to the Pro-Ject DAC. When I listen through the Android App or on my MacBook, I don’t hear any noises. But I do hear noises without the Headphone Amp when I connect the DAC directly to a Naim Supernait. I already tried different cables - with and without an iFi iPurifier 3.

Hi @MartinD,

If you play the same content to this device from the same machine in a different app besides Roon do you experience the same noises?

Can you share the signal path when playing this content to this device in Roon?

Can you share a screenshot of device setup as well?

Sorry for not mentioning this, but I cannot play the content from the NUC in another app since only ROCK is running on the NUC. But when I play the exact same content from my NAS on my Oppo 105D which is connected to the DAC with a coaxial cable, there are no noises.

Hello @MartinD,

We are investigating this report with our Roon Tested hardware. We will reach out to you with the findings of our tests as well as some next steps shortly.


Hello John,

Pro-Ject released a Firmware Update in January. Looks like this solves the problem.

Hello @MartinD,

The QA lab was unable to reproduce this issue with our in-house DAC on the latest firmware, so I’m glad to hear this was due to the firmware issue. I will be marking this thread as solved in case other users search for these terms, let me know if you are still seeing issues in the next day or two.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.