Clicking on Contact Roon Support Link (within Roon) takes me to ELAC Forum site [Ticket in]

@support May as well start with the subject line: what is up with that?

But I also have question (hence clicking on the Roon Support Link).

I have had, since I began using Roon, an intermittent connection with my Sqeezebox Touch. Various strategies of quitting Roon, or restarting computer that Roon is on, or restarting the Touch or some magical combination of those three, eventually get it back on track. Although sometimes with a glitch (the latest–which is new–is that my Android phone won’t control the Touch but my MacBook laptop will).

I’ve pretty much given up hope of resolving this problem with the Touch (I can literally go months with no problem at all and then it just starts acting up for no rhyme or reason that I can discern).

So my question is whether a “Roon-approved” device is likely to solve this problem. Put another way, is this a network problem or a problem with the Touch. Is there a way to tell?

Set up: Roon on a MacMini; Music Files on a External Drive connected to the Mini; Touch/MacBook etc. connected to Mini via Airport Time Capsule. All computers running MacOS 10.12.6

Hi @James_Bailey ----- Thank you for the feedback! In regard to the “support link” our devs have been made aware and will be addressing the issue accordingly.

This behavior you’ve reported could very well be related to some sort of bottle neck occurring on your network. I will say the first thing that jumps out at me immediately is the use of the Apple Time capsule, as we have seen issues with these devices in the past. Our CTO Brian wrote a very informative post about the use of WiFi in home networks that is definitely worth a read, as he covers what a strong setup should resemble. Even with a “RoonReady” device in place, if there is an issue with the network you still will not receive optimal results.

With the above in mind, besides what you’ve provided already in your description, are there any other networking devices present in your topology? If not, during your troubleshooting of this behavior have you tried…

  • (If not in place already) … A hardwired connection between your Roon core (MacMini) and the router you are using?

  • A wired connection to the Squeezebox Touch and the router you are using?

  • While this may seem rather elementary … besides power cycling the app, core machine, and touch, have you tried rebooting your networking hardware as well (i.e the Time capsule etc)?

You mentioned that you’ve made the following observation:

“Although sometimes with a glitch (the latest–which is new–is that my Android phone won’t control the Touch but my MacBook laptop will).”

Can you please provide some further insight into this behavior? When you do notice this problem with the Android phone, what specifically is happening? While in this state, what functionality DOES the phone have (i.e can you control other endpoints? etc)? Does the phone lose connection with your core machine or does it stay connected?


Thanks Eric. I’ll have a look at Brian’s post when I have the time. Starting with the last question and going in reverse: the Android phone does not appear to be connecting to the core machine (the on-screen message says something like “it is taking longer than usual for Roon to connect…” That happens from time to time but usually it does eventually connect. Not yesterday. It never connected. Haven’t tried it today

I haven’t tried power cycling the networking hardware. I’ll try that.

Neither the Touch nor MacMini is hardwired. I did once run a long ethernet cable from the Touch to the Time Capsule. And then again from the Time Capsule to the Mini. In neither case did I notice much of an improvement. But I never connected BOTH the Touch and the Mini to the Time Capsule simultaneously (didn’t have long enough runs of ethernet cable handy). I suppose that is the next step. Because of the locations of the various components of the network (Touch, Time Capsule, Mini) that will be a project (at least to do it in a WAF acceptable way). But it sounds like something I’m going to have to do (especially given the next paragraph).

There are numerous other devices on the wireless network (and they seem to be proliferating). It’s embarrassing to even list them but here goes: another Squeezebox (Classic); Squeezebox Radio; laptops (2), my wife’s phone; TV; DVD player; TIVO; Apple TV; Amazon Echo; Amazon Echo dots (3); TP Link WiFi smart plugs (3). FWIW, the Amazon devices and smart plugs are recent additions and this problem definitely predated their arrival.


1 Like

One more question. Having read Brian’s post I see that he mentions the Asus RT-AC5300 as a recommended wireless router. Is that still current? Is there a list of Roon recommended wireless routers somewhere (a quick search didn’t reveal one)?

1 Like

Any recommendations needs to be filtered for your own use case, however, that is a beefy Wifi unit and I’ve always had good luck with Asus and that recommendation is only 6 months old, so I’d count that as still being relevant. I’d give it a thumbs up :thumbsup:

As I read your list of “proliferated” wireless devices, I would suggest, if you have not done so already, that you begin moving some items onto 5 Ghz and leaving others on 2.4. That might help clean up some issues. However, which devices are better on which band takes some experimenting. For example, my Echo has connection issues (as does my Samsung phone) with the 5 Ghz band, so they are both on 2.4. The Amazon fire TV has no such issues and is on the 5 Ghz band.

1 Like

Hi @James_Bailey ----- Thank you for touching base with me and giving the posted link a read. Very appreciated!

Whenever troubleshooting anything network related, I always recommend shortening the chain of communication down to it’s bare minimum and then adding the “links” back in. Using this method of trial and error is (IMO) the best way to identify where things are succeeding and where they are failing. I would also highly recommend considering the advice offered by @Rugby (::thumbsup:)

Please do share your feedback/observations with us once you have performed your testing.


I too am getting the Elac redirect. Unable to file a trouble ticket. My issue is that in the past 3 days I am unable to have Roon see my PSAudio Directstream DAC, connected by its Bridge II.

I am now able to see the PS Audio device again. Very confusing. Lots of power cycling, maybe that is what helped.

Hi, @B_Felt! Thanks for the report, we put in the ticket about this issue, so we’'ll have it fixed by our next release. Thanks!


Just a follow-up to my intermittent Squeezebox connection problem mentioned above. Long story short, I ended up purchasing a Linksys Velop router system (a mesh network) which has pretty much brought an end to my problems. I bought three of the units and, truth to be told, I could probably still use a couple of more but I think I have them arranged now that the problems with my Roon connecting to the Squeezeboxes has gone away. That’s a great relief.