Clicks played at beginning of DSF tracks - Linn Klimax Katalyst (v4.73.326)

Setup: Antipodes CX 2.7/Roon 1.6 Build 416 => Linn Klimax Katalyst ( firmware: Davaar 73 Build 326 (4.73.326))

Issue: When playing DSD64 (stored in DSF files) album using lossless signal path (purple) in Roon, at the moment the track is changed to the next track of the album a small “click” is audible. This does not happen when playing PCM content. I am only using Roon server since the Linn handles rendering itself.

Connection: Antipodes CX => Direct Ethernet => Linn Klimax Katalyst

Since the Antipodes CX also has MinimServer available, I have tested the same files using Mimimserver and they play flawlessly. Minimserver plays DSD files natively as well. Since the Linn is OK with Mimimserver running on the Antipodes CX I think I need to adjust a setting in Roon somewhere. Any thoughts?

You could perhaps try DSD upsampling all your tracks to a fixed output format and see if that helps. Maybe it’s the DAC dropping in and out of DSD that causing this. At least for troubleshooting.

1 Like

Hi @Deejeeb,

Welcome to the forum! I would try increasing the Resync Delay in the zone’s Device Setup tab to see if it helps. Otherwise, you may want to try to see if up-sampling all your DSD content to the same rate using the DSP Engine helps (as @wizardofoz mentioned) .

Thank you for the suggestions. I tried various resync delays to no avail. I also specified custom upsampling to DSD128 as suggested - unfortunately this does not help either.
For now, I have entered a custom method to PCM 192 Khz, in which I can confirm there are no clicking sounds anymore on track change. This leads me to believe the “click” is not in the file itself.

Of course I would like to stick to DSD native transport of the file to the network player, without having to resort to this. The thing that puzzles me is that the combination Minimserver/Linn Klimax Katalyst is playing the files flawlessly. I hope some other setting in Roon may be changed for this.

Hi @Deejeeb,

Thanks for giving that a try. I’m going to reach out to our hardware team to see if they have a Linn zone in-house and if they do, I’ll see if they can attempt to reproduce your findings.

Thank you for looking into this issue! Since the Linn is “Roon Tested” I would expect playing DSF is tested as well.

I verified the software for the Linn. The correct software for the Linn is:
Davaar 70 Build 300 (4.70.300).
The unit itself reports:
Software Version 4.70.300
Software Variant Fw999

1 Like

I performed another test with an interesting result. In Roon, I configured a custom DSP for 44 Khz 16 bit to DSD64. The issue I encountered for DSD files is now also present for 44 Khz 16 bit files! For me, this is proof it is not related to content (since the issue now also manifests in PCM) but has to do with the transport of DSD data by Roon to the DAC, and occurs on track change. I think this is important for you to understand the issue at hand.

Can you screen shot the device settings…maybe there is something there we can draw on to help. Are you using exclusive mode if its an option?

Sounds like it could be a muting/unmuting issue and when this happens do you see any indication on the DAC of any drop in sync or change of status or bitrate?

Im not familiar with Linn so forgive anything that might sound like im clutching at straws :blush:

Any kind of help is always appreciated! Since I only use Roon server, and not Roon ready I have no influence on aspects like Exclusive Mode. As can be read in the Linn expects a native DSD stream, which Roon is able to provide since music is played. The Linn itself is a fairly closed system, but is able to display the bit rate when playing. I will check if this provides an insight!

The Linn displays 2.8224MHz / 1bit (it is a DSD 64 file), but upon track change this is temporarily replaced with the name of the new track. That is not helpful I’m afraid.

Hi @Deejeeb,

I spoke to our hardware team and they have been unable to play DSD content in the lab, but they do not have your exact Linn DAC model, so it is possible that there is a discrepancy here between device capabilities.

Can I ask - have you by any chance reached out to Linn regarding this issue yet? If you haven’t, I would definitely suggest doing so as they might be more have more device-specific settings that may be applicable here.

I have reached out to Linn as well. I would expect any kind of model of Linn equipped with the Katalyst DAC could be used to test this.

I received word from Linn that this issue does look a lot like an issue there are working on at the moment and it should be resolved in the next release of Davaar firmware! Hopefully, this is the case and I will report back when the new firmware is installed.

1 Like

Hi Deeieeb

I am suffering from the same symptom. By returning Linn’s firmware to Fw961_4.68.267
It has been solved.

I’m looking forward to the next farm solution.

1 Like

Thank you for the update here @Deejeeb!
Do let me know once the new firmware is out and if this resolves the issue!

Hi Masaaki,
Thank you for your post. I could not react to it any time sooner since my power amp was down, but this is solved now. I was unable to restore to FW961 however due to the fact that the firmware is not compatible with my Klimax DS. According to the instructions of Linn, you then need to go to the last ‘Component’ release which is KlimaxDsMk5_4.63.223. Having installed this, the issue with the clicks is gone! I am not sure what I am missing in terms of updates on the code since that release, but for now I am sticking with this release. I am still waiting on the solution in a next version of firmware of course, but for now I can enjoy DSD without the irritating clicks.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.