Clients unable to select core attached audio devices or library

Core - Win10 - connected direct to router
Clients - Win10/Ipad, direct to router/wireless
Using HQPlayer (on Core), Microrendu NAA Client

Description Of Issue
Music stopped today with message on the iPad - database problem. I used the Win10 client to load a backup from last night. After reloading backup the clients Win10/Ipad could connect to the core but could not select or “see” any of the core connected audio devices or the library. The audio device section in settings was a blank (not even local devices) and there was no library (Roon shows a message that a hard drive may be offline) - it was as if I had a partial connection to the core - I could see settings, backups, etc. but not audio devices/queue, albums, etc . I tried three other backups including one from months ago that I had saved. No dice.

Uninstalled Roon Core, reinstalled core/client on the core machine. Reimported and re-setup Roon from scratch from the client on the core machine. Gave the new core a new name “MusicServer”. Everything worked great. The client saw all the audio devices, the reinstalled library was there and I could play through HQPlayer to the microrendu. External clients continued to have same problem - seemed to try and connect to old server name.
I don’t want to run the client on the core machine so uninstalled the new core/client and installed just Roon Server (core). Restored this core from the working backup. With no client on the server I am back to using my usual clients - still unable to fully connect. At first they identified the new core install with the old name but after disconnecting from core the connection showed the new name. After all this, the clients are still in this semi-connected state - no audio devices, no library. Uninstalled and reinstalled clients - basically I have an all new install - core and clients- the newly installed clients cannot make a functional connection to the newly installed core. I don’t know what else to try. Have been using Roon for years and have swapped cores around to different machines over that time and have never had a problem this confusing to me. It’s been an all day situation. Hope you have some ideas. Thanks.

I got in a funky situation similar to what you are describing.

The only way I could fix it was to delete the Roon library. Even if you have deleted and reinstalled Roon, Roon’s library hangs around.

Still, you probably should wait until @support has their say.

Hi @Robert_Hansen,

Thanks for reaching out and welcome to the forum. I am a bit confused with some parts of your message, but let me try to advise on what I understand and request clarification on what I don’t:

This does sound like corruption so good idea towards restoring the backup. The only other thing I would suggest prior to restoring the backup is to set your old database location aside as @xxx suggested, here are the steps on how to do this:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder

When you set up a new Core (or Database for this matter), the old one should not be visible any longer. On your Roon Remotes/Clients you will need to click on the “Choose different Core” on the Select your Core screen and select the new database instance.

The Roon Client app can also act as the Core on a PC since the Client is an “All-in-one” application. RoonServer can host the Core as well, but it has no user interface.

You can even have both RoonServer and the Roon Client on the same PC and they will work just fine togather, RoonServer will manage the Core and the Roon Client will connect to the RoonServer instance on the same PC.

Which backup did you restore on RoonServer, the one you created after re-installing the Core?

It sounds like your Clients are still connecting to the old database location.

As for next steps, here’s what I would do:

  1. Set your old problematic database location aside using the “Roon_old” instructions I outlined towards the top of this post.

  2. Try restoring your database from one of the backups again, start off with one at least a week before this issue occurred

  3. Connect your Roon Clients to the restored Core and check to see if this backup works as expected

  4. If the backup does not work, perform the Roon -> Roon_old rename once more (call it Roon_old2 or something similar) and try restoring an even older backup

  5. If you exhaust all of your backups and none seem to resolve the issue, unfortunately you will need to use a fresh database to proceed, which can be achieved with Roon_old but not restoring any backups.

  6. If any of your Roon Clients in particular are having issues, you can set the old Client database aside using the same Roon_old instructions as well (Clients have a Roon folder as well that can be re-installed in the same database location as the respective machines)

Can you let me know how that goes? If you have any issues or get stuck, some screenshots of where you’re stuck at would be helpful to debug further. Thanks!

Thanks @noris and @xxx.
Everything is back to normal once I restored into a new database. Looking back I clearly went through many extra, unnecessary steps just because the symptoms seemed so weird and I didn’t know how easy it was to regenerate a new database in Win10 (no new install necessary). Thanks !!!

1 Like

Happy to help @Robert_Hansen!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.