Clipped/distorted AACs since 334 on Nucleus only (MacOS OK)

Hallo, ran into something weird yesterday, that took me a little while to reproduce – unfortunately it’s lights-on-lights-off now.

Since the latest update (334 / chromecast) I have issues that songs (AACs) that have been playing just fine forever are being clipped/distorted on my Nucleus+. Happens with any audio device (USB-DAC, AirPlay, Chromecast etc pp) – no matter ist attached by USB, Ethernet, WiFi etc pp.

Running exactly the same songs on my MacOs based Roon (backup) server everything is fine. The songs play well also from other sources like iTunes, Audirvana etc.

The corresponding songs from TIDAL play fine as well via the Nucleus+…

What I did:

a) Ripped a CD (years ago) using CD Ripper from dbPoweramp as AAC.
b) copied the songs to the Nucleus+. CLIPPED/DISTORTED.
Example: 03_Business As Usual_Down Under___CD_BAD.m4a
c) resampled the same songs using Music Converter to FLAC.
d) copied the songs to the Nucleus+. FINE.
Example: 03_Business As Usual_Down Under___CD_BAD_FLAC_OK.flac

Please note: it’s the SAME song just resampled – the original fails but the resampled version works fine.

e) re-purchased one CD/album fresh from iTunes.
f) copied the songs to the Nucleus+. FINE.
Example: 03_Business As Usual_Down Under___iTunes_OK.m4a

Note: in order to identify the songs/files I have changed tags and filenames using Metadatics app.

I ran across other support threads like Build 334: AAC 24bit conversion - audio artefacts [Resolved B339] on distorted sound on build 334 mentioning missing AAC codecs – I therefore followed the instructions there and installed the ffmpeg file in the codecs folder of my Roon. Didn’t change anything – BUT I’m not sure If the codecs is working as it should (is there any indicator within ROON to see if I did this right?).

If needed I can send you the three different versions of the file – other than that they are placed one the top level of the Internal storage of the Nucleus. Screenshots of the file information of the three songs form within ROON attached.

Any help appreciated.

Best regards,


Hi, @Lorenz_Ismer, sorry to hear about your troubles, could you please give this thread a read and see if it’s a similar problem to the one you are describing?



@ivan – thanks for your quick response.

Actually I did ran across that thread – I did even mention and link the thread my post :-).

I thought that missing codecs (the ffmpeg file) would be it – downloaded and installed as instructed at unfortunately I see no improvement after a starte of the server or rebooting the Nucleus.

BUT (again as mentioned before) I’m not 100% sure I downloaded the correct version of the ffmpeg file and installed it the right way at the right place.

I have downloaded the two archives marked in green in the first screenshot. Extracted them and installed ONE of the (the stable 401 plus the daily build) ONE at a time. Same result.

With regards to installation I took the ffmpeg file and placed it on within the Codecs folder that I see when connection to the Nucleus+ (share is called data) – second screenshot attached for reference. Restarted the Roon server (app) and rebooted the server to no avail.

My question again – is there any indicator that THE ffmpeg file/codec has been installed correctly and works as it should be?

Best regards, Lorenz

UPDATE: I have sent the three different versions of the same song to my Nucleus+ dealer, they put the files on a USB stick ans attached it to their Nucleus: same result :-(. One file – that was working fine before and works fine on the MacOS version of the Roon server – distorted :-(.

So: different Nucleus+ and different Audio devices – same result.

@Lorenz_Ismer — Thank you for your feedback and sharing this observations you have made since taking the update to B334. The insight has been greatly appreciated!

I have went ahead and opened up a ticket in our system containing all the information you have provided here. Our tech team is currently investigating and once I have an update on their progress I will be sure to touch base again ASAP.

In the meantime, may I very kindly ask you to please send over the media you mentioned in your most recent post via a shared dropbox link in a PM addressed to me for testing purposes.

Again, thank you for your patience and understanding while we try to get to the bottom of this!

+1 on heavy clipping on aac files since 334. I had to add in an additional -2db of headroom to control the clipping.

I’m running fedora 24 on my core, aac was from tidal.

The top post in this thread depicts an AAC file that Roon’s dynamic range metric determines to have a 5.2 dBTP. That almost certainly cannot be accurate, as that would be massive clipping due to intersample overs. Something appears to be very wrong in Roon’s newly implemented 24 bit decoding of lossy compressed files.


Headroom (or any other DSP setting) does not affect the clipping in any way. It’s always there, always (at least it sound like it) with the same level/strength.

Hi @Lorenz_Ismer ---- Thank you for the follow up! Confirming that I have seen your PM and have downloaded/attached the media to your ticket for our tech team.


@Lorenz_Ismer – take the update and try again.

Roon -> Sidebar -> Settings -> About – this will trigger the check

Nucleus does not use ffmpeg like this… it ships with codecs

@danny – unfortunately my Roon app does NOT show any update yet – current status as per screenshot. how can I identify the update (build version – where to find?)…

if the update was silent – to has no impact – still clipping like hell.

you are already running it… build 7 – try your aac now

Rebooted the Nucleus – NOW it sounds OK – clipping seems to be gone. :grinning:

Still – one (minor) glitch – the waveform of the “BAD” file is still weird – ist looks almost like a block…

You have to tell Roon to reanalyze the album.


@WiWavelength just did this – same waveform.