Clipping audio with Chromecast Audio

I grabbed the 1$ for three months offer to continue my Roon subscription. I faced a problem with some clipping audio when the signal path shows MQA decoding. If MQA is not present, the files play normally. I only use Tidal as a source. Not sure if this is a limitation of Chromecast, or the DAC I’m using. Is there a way to lower the sampling frequency to 44.1 Khz for all files?

Roon Core Machine

Mac Mini M1

Networking Gear & Setup Details

Huawei B315s-22

Connected Audio Devices

Chromecast Audio, Dspeaker Anti-Mode 2.0 DAC

Number of Tracks in Library

Tidal streaming only

Description of Issue

Turn off Roons MQA decoder for that zone, it will then not perform MQA unfolding so you get 44.1/24 passed through.


What’s the problem you face? How do you know it’s clipping?
Other users had issues in the past with the optical output of the CCA (wrong connector, bad connector fit, insufficient quality of the adapter).

Note: Small amounts of clipping as a result of up-sampling are usually inaudible.

You can add a little bit of headroom to prevent clipping:

I think actually clipping may not the right term to use here. Perhaps garbled or distorted would be a better way to describe it.

But I found the MQA decoder setting from CCA zone and switched it off, so it seems that now it’s performing alright.

Sounds like the DACs the issue. I have played mqa to my Chromecast dongle and it’s been fine.

1 Like

Mqa played to all three of my CCA puck’s works fine to my ears.

AFAIK is the processing in the DSpeaker done in 48 kHz resolution anyway. So no matter what sampling frequency is accepted on the inputs, it all ends up as 48 kHz for processing and then on to the integrated DAC. So I would limit the zone to 48 kHz in Roon (disable MQA unfolding as it always leads to 88.2 or 96 kHz resolution; no MQA support in the DSpeaker Anti-Mode 2.0).

1 Like

I checked the DSpeaker manual, it says

Toslink S/PDIF input: 24-bit 32 / 44.1 / 48 kHz and 88.2 / 96 kHz compatible

So in that sense it should be able to handle MQA core decoder.

I don’t really understand this MQA thing, but if I get this thread right, disabling the MQA core decoder would still give the lossless Tidal output.

Yes it’s just the unfolded mqa stream. But being MQA it isn’t technically lossless as it’s a compressed source using their oragami. Roons transmission of it is lossless though.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.