Clock is way off

Hi @spockfish,

Recently the clock on my setup has gone out of sync. Tried to reboot, etc.

Can you tell me what should I do to further check what could be wrong?

Thanks.

Is this by minuets or hours off, maybe the time zone is incorrect if it’s hours off, if not then maybe it’s a faulty rpi?

Double checked the time zone, all correct, but it is showing a date of 7 July… it is like the system is nit picking up the right time from the network.

nope, this means NTP is not working. Can you send me feedback?

Done. 65eb063255c5dfca

Thanks in advance.

I can’t read your feedback, the file is corrupted.
I’m afraid it’s time for a reflash…

Hi @spockfish

I’ve changed the SD Card, fresh image and installation but the date/time is still showing Friday, July 6th 4am, at the time I am sending this post.

I’ve triggered another feedback: e12ab835d3220756 - can you help to have a look please. Is it my RPi that has gone bad? Or is the connection to the NTP that is not working?

Thanks, Noel

maybe some way to force NTP to get the time or set it manually with SSH

There’s nothing wrong with your Pi, it’s just NTP that is timing out.

Has something changed in your infrastructure? Router etc?

I’ve reflashed new version of ddwrt on my router. Let me do some check.

ah…now the truth comes out :smiley: bet maybe e some funky firewall setting or DNS issue

Hi @spockfish, @wizardofoz,

which NTP server is being used by Ropieee?

Thanks.

it’s a set from the NTP pool project:

0.arch.pool.ntp.org

and then 0 - 4.

Thanks.

I’ve confirmed that there’s nothing in my router that block NTP, and when I SSH-ed into Ropieee, and run the ntpdate -qu 0.arch.pool.ntp.org, I’m getting:

[root@ropieee systemd]# ntpdate -qu 0.arch.pool.ntp.org

server 209.58.185.100, stratum 2, offset 9221627.369527, delay 0.02896

server 118.140.184.99, stratum 2, offset 9221627.371405, delay 0.02992

server 203.95.213.129, stratum 3, offset 9221627.379954, delay 0.02902

server 45.125.1.20, stratum 2, offset 9221627.370224, delay 0.03012

6 Jul 04:03:45 ntpdate[10389]: step time server 209.58.185.100 offset 9221627.369527 sec

[root@ropieee systemd]#

which if I got this right, shows that it is able to connect to the NTP server, but yet, it is showing 6 Jul date…

any pointer that you can give me to resolve this please.

ok. let’s see if this is a timeout issue. Can you do a:

systemctl stop ntpd
systemctl start ntpdate
systemctl start ntpd

It failed at systemctl start ntpupdate with the following message:

[root@ropieee systemd]# systemctl stop ntpd

[root@ropieee systemd]# systemctl start ntpdate

Job for ntpdate.service failed because a timeout was exceeded.

See “systemctl status ntpdate.service” and “journalctl -xe” for details.

[root@ropieee systemd]#

when i did “systemctl status ntpdate.service” this is what comes up:

***** ntpdate.service - One-Shot Network Time Service

Loaded: loaded (/etc/systemd/system/ntpdate.service; enabled; vendor preset: disabled)

Active: failed (Result: timeout) since Fri 2018-07-06 04:08:40 HKT; 1min 12s ago

Process: 10711 ExecStart=/usr/bin/ntpd -q -n -4 -g -u ntp:ntp (code=exited, status=0/SUCCE>

Main PID: 10711 (code=exited, status=0/SUCCESS)

Jul 06 04:08:40 ropieee ntpd[10711]: 6 Jul 04:08:40 ntpd[10711]: 81.7.16.52 local addr 192.>

Jul 06 04:08:40 ropieee ntpd[10711]: 6 Jul 04:08:40 ntpd[10711]: 95.211.120.4 local addr 19>

Jul 06 04:08:40 ropieee ntpd[10711]: 6 Jul 04:08:40 ntpd[10711]: 118.140.184.99 local addr >

Jul 06 04:08:40 ropieee ntpd[10711]: 6 Jul 04:08:40 ntpd[10711]: 203.95.213.129 local addr >

Jul 06 04:08:40 ropieee ntpd[10711]: 81.7.16.52 local addr 192.168.1.152 -> <null>

Jul 06 04:08:40 ropieee ntpd[10711]: 95.211.120.4 local addr 192.168.1.152 -> <null>

Jul 06 04:08:40 ropieee ntpd[10711]: 118.140.184.99 local addr 192.168.1.152 -> <null>

Jul 06 04:08:40 ropieee ntpd[10711]: 203.95.213.129 local addr 192.168.1.152 -> <null>

Jul 06 04:08:40 ropieee systemd[1]: ntpdate.service: Failed with result ‘timeout’.

Jul 06 04:08:40 ropieee systemd[1]: Failed to start One-Shot Network Time Service.

and on journalctl -xe, this is what it says:

[root@ropieee systemd]# journalctl -xe

Jul 06 04:09:16 ropieee ropieee-touchui[8003]: NavigationController::processState() start scre>

Jul 06 04:09:16 ropieee ropieee-touchui[8003]: qml: PlayerWindow:onStateChanged: paused

Jul 06 04:09:16 ropieee ropieee-touchui[8003]: NavigationController::processState() start scre>

Jul 06 04:09:16 ropieee ropieee-touchui[8003]: NavigtationController::processState() screensav>

Jul 06 04:09:16 ropieee ropieee-touchui[8003]: Mqtt::messageReceived: Player object: writing p>

Jul 06 04:09:16 ropieee ropieee-remote[7312]: discovery timeout

Jul 06 04:09:26 ropieee ropieee-remote[7312]: discovery timeout

Jul 06 04:09:36 ropieee ropieee-remote[7312]: discovery timeout

Jul 06 04:09:46 ropieee ropieee-remote[7312]: discovery timeout

Jul 06 04:09:56 ropieee ropieee-remote[7312]: discovery timeout

Jul 06 04:10:06 ropieee ropieee-remote[7312]: discovery timeout

Jul 06 04:10:16 ropieee ropieee-remote[7312]: discovery timeout

Jul 06 04:10:26 ropieee ropieee-remote[7312]: discovery timeout

Jul 06 04:10:36 ropieee ropieee-remote[7312]: discovery timeout

Jul 06 04:10:46 ropieee ropieee-remote[7312]: discovery timeout

Jul 06 04:10:56 ropieee ropieee-remote[7312]: discovery timeout

Jul 06 04:11:06 ropieee ropieee-remote[7312]: discovery timeout

Jul 06 04:11:16 ropieee ropieee-remote[7312]: discovery timeout

Jul 06 04:11:26 ropieee ropieee-remote[7312]: discovery timeout

Jul 06 04:11:36 ropieee ropieee-remote[7312]: discovery timeout

Jul 06 04:11:46 ropieee ropieee-remote[7312]: discovery timeout

Jul 06 04:11:56 ropieee ropieee-remote[7312]: discovery timeout

Jul 06 04:12:06 ropieee ropieee-remote[7312]: discovery timeout

Jul 06 04:12:16 ropieee ropieee-remote[7312]: discovery timeout

Jul 06 04:12:26 ropieee ropieee-remote[7312]: discovery timeout

Jul 06 04:12:36 ropieee ropieee-remote[7312]: discovery timeout

ok. that log is not related.

Can you do:

systemctl stop ntpd
ntpdate pool.ntp.org

[root@ropieee systemd]# systemctl stop ntpd

[root@ropieee systemd]# ntpdate pool.ntp.org

6 Jul 04:19:14 ntpdate[11458]: no server suitable for synchronization found

[root@ropieee systemd]#

…strange… is my ISP blocking NTP?

yeah that might be the case. Some do that unfortunately.

Can you do:

ntpdate time.google.com

same thing. Calling the ISP now…