Cocktail X14 files not showing in Roon

Roon Core Machine

Roon Core is Windows, an LG Gram Laptop
Intel(R) Core™ i7-8550U CPU @ 1.80GHz 1.99 GHz

Networking Gear & Setup Details

Wirless Netgear Orbi Routers on Cellular Network

Connected Audio Devices

CocktailAudio x14

Number of Tracks in Library

1TB , ~15k tracks so far

Description of Issue

Roon cannot see my x14’s drive to add tracks, though I do see it in the Roon as enabled. I have turned on Samba server, and the Cocktail is showing as a Media Device in Windows Explorer.

When I do add the Cocktail to the folder list, it shows up as empty, even though there are folders in Windows that I can access and have content:

I’m two hours into my Roon trial and about ready to call it quits, this has been such a hassle.

What type of files are your music files in the x14?
Roon does not “see” wma files for example.

Not the issue, thanks: mp3, FLAC.

How are you “adding the Cocktail to the folder list”?

There are two ways:

  • via adding a Network Share in Roon
  • via “Mapping a network drive” in Windows, and then adding the folder in the mapped drive to Roon.

Your screenshot doesn’t seem to be using either of these methods.

(the first method is the one that I prefer)

1 Like

I tried adding via Network Share in Roon, and every combination of IP and folder names comes back with Invalid File Path. I have tried both MusicDB and HDD1 as the folders.

When I try the latter method you describe, using the same paths, my computer just hangs.

So, are you sure that your X14 is sharing its music folders out on the network? And if so, what username and password is expected for the access credentials? Thanks.

According to this, I am (fairly) sure.

The username is guest and there is no password (according to the screens on the device).

And I didn’t see it, but when I tried to map the network drive, it said that it couldn’t access it in a background pop-up. It did request credentials though, so it must be seeing it.

Since password was blank, I just entered one, just in case, and am trying that.

Yes, that’s a media device - but that’s (I think) showing that it’s a DLNA UPnP device - and Windows isn’t seeing shared folders on the X14.

If Samba is enabled, would it show by default, or is there an extra step I am missing?

Yup - you’re missing an extra step. Hold on…

It may not be possible to have the X14 configured for file-sharing access - I’m not familiar with the device. If it is, then it should be showing up as a computer in the top section of Windows File Explorer:

Then folders in the X14 need to be explicitly shared over the network before they are seen by other devices on the network…

It seems to me that you have work to do in the X14 to set up the folders for network access before you can add them into Roon…

The device is labeled as Roon Ready, so I wouldn’t think there would be additional hoops to jump through… Thanks for trying though.

The Roon Ready branding is to do with it being a network streamer using Roon’s RAAT protocol. You’re trying to do something else entirely different…

I guess I am misunderstanding then, because I understood the point was to unify libraries across all devices. If it is not accessing the library of my primary listening device, then that is rather pointless.

Wait, I got it.

I’m looking at pages 51 and 52 of the X14 user manual at the moment. That is telling me that you need to enable the Samba server, and then you should be seeing the X14 in the computer section of Windows File Explorer as I showed above.

I’m going to have to leave now - I’ll catch up with you again tomorrow…

I entered the IP address in the search bar on Windows, it opened up the music server and allowed me to map it as a network drive, where when I tried to map directly from the Windows Explorer function, it would not allow it.

It appears to now be syncing my library, though only a few artists so far have populated.

Sounds like you are getting there.
Now what do you have your analysis settings at in settings: library.
AsRoon is going to do a full analysis of your imported library and that can be cpu intensive