Codec file requirements?

Continuing the discussion from Moving to NUC ROCK:

I just loaded ROCK on my new NUC and it works fine. The ROCK instructions say I need to load a Codec file (ffmpeg) onto the ssd of the Nuc, which I haven’t done, but as I said, so far streaming Qobuz with no problems. Has the ROCK download incorporated this Codec file eliminating the need for the extra step?

Hi @Jack_Glen and welcome to the forum.

No it has not. You need ffmpeg if you intend to play music encoded with certain codecs (AAC, MP3 and maybe others). Read the Guide about how to install: Roon OS Missing Codecs.

If you navigate to the ROCK web UI see if it it says this:

If it does say the above, you need to load the ffmpeg codec.

If the codec is installed it should say something like this:


Just by way of explanation as to why users need to install this codec themselves. The ffmpeg codec is proprietary software that is made available free of charge to individual end users but charged to resuppliers. Roon makes ROCK available free of charge and has chosen to provide users with instructions to install the codec rather than introduce a fee to recover the ffmpeg licensing cost if it were bundled with ROCK.


Thanks. Can you please explain how to get into the ROCK web UI?

After some research I was able to find the web UI, but it says the Codec is not there even though I copied the file into the codec folder. Do I need to reboot the NUC? If so, does that mean turning it off then on? Or is there a reboot possible from inside Roon?

Found the reboot on the web UI, but still says missing codec. I looked and ffmpeg file is in the codec folder.

Have you uncompressed the downloaded archive twice as per the guide and extracted the ffmpeg file ?

If you can link a screenshot showing the exact contents of the codec directory that would assist.

Yes, I did the double uncompress. A screen shot follows. When I copied the file there was a point when I was warned that there was an existing file - I chose to skip - but when I look at the original file and the one in the Rock Codec folder, they are the same size.

That looks right to me. Try restarting the whole device. If that doesn’t fix the message I’m out of ideas and we’ll try Support.

This codec problem comes up very often here on the forum.

For me as a Linux user it was a bit more complicated, because there were still problems with the file permissions.

I would like to support the in my opinion simple (please don’t get “simple” as primitive :wink:) but great idea of @Tor_Gunnar_BerlandUpload of codec in ROCK WEB interface”. This would reduce a lot of support requests.


See upthread where I mentioned that ffmpeg is free to end users but requires a licence payment to be bundled. Roon prefers to keep ROCK free rather than impose a charge to cover the licence fee.

If you are thinking of a smoother support of uploading codec pack via web interface. This in no way breaks with any license payment for bundling the codec packs. It is a way for each user to upload them without the challenges they get now with manual copying it.

Upload button; upload the required codec file and the ROCK handles putting it in the right place with right access level.

Thanks for being so responsive. By restarting the device, do you mean turn off and then on? This is a first since I just started using the NUC. Do I need to close ROCK before turning off?

Use the web interface power button.

The easiest way would be to simply upload the compressed ffmpeg file and ROCK then does the rest (unzip and copy to the correct directory + restart ROCK).

I’m not really shure if I have understood you hundred percent correctly. It is clear that Roon is not allowed to deliver the codec for legal reasons. But as an end user I have to download the codec manually anyway. And then it doesn’t matter if I copy it manually via a file editor or via the web interface of ROCK.

I was able to solve the problem with the help of the Roon support team. It turns out the instructions for installing the codec file are incorrect/out. Of date. I copied the ffmpeg file as per the instructions. Roon support told me to copy all of the contents of the downloaded “static” folder. After a reboot it works fine.


That is interesting, I would say that the instructions aren’t necessarily “incorrect” just that they may not cover your situation. When I set up my ROCK and when I was doing the testing just now I followed the process in the instructions and it worked for me.

Out of curiosity can you post a screen shot of what is in the Codecs folder now for you? I would like to see what ended up in there.