Codecs Missing on ROCK

Core Machine (Roon Optimized Core Kit / NUC8i3BEK / Version 1.0 (build 174) stable)

Issues with missing codecs.

Description Of Issue

The ffmpeg build ffmpeg-git-20190527-amd64-static has bin copied directly into the Codecs directory on the smb share but ROCK still says that codecs are missing. I have read that there might be a permission error but there are no permissions I can set over smb. My client is Nautilus on Manjaro using gvfs-smb. I tried different builds of ffmpeg but nothing worked. I’m just setting up the core for my parents, who bought a license for one core. Is there something I haven’t tried yet?

You uncompressed it, right? After you uncompress it on whatever computer you are using (I downloaded and uncompressed it on my PC) you just need to pull the one file ‘ffmpeg’ (68.0 MB) to the Data\Codecs directory on the Nucleus.

I did and thank you for your quick answer. I found the issue and it was indeed just permissions. I could set them on windows, just not on linux:

I think this is something that roon might want to fix automatically. Just to avoid issues with non-Windows systems.

1 Like

7 posts were split to a new topic: ROCK won’t recognize ffmpeg

It sounded like you knew what you were doing, but ya’ never know…

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.