Codecs went missing in Rock

Core Machine (Operating system/System info/Roon build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Intel NUC gen 8

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

My system has worked great for a long time! Suddenly Rock lost the codecs and could not find the harddrives with the music anymore! I have followed your instructions, i e downloaded ffmpeg and tried to copy it to \ROCK\data\codecs but will not take it!

when I restart Rock I have lost everything, music, all playlists and even the the Rock Hqp player?!

Now I managed to start up Hqplayer so I can play Tidal! Everything lse is lost!

Sounds like a possible SSD corruption, did you try a reinstallation from the GUI?

Maybe post a screenshot of the WEB based GUI screen too.

Have you tried to restore a backup?

What do you mean …GUI? I cannot backup as all backups are on the USB harddrives!

OK so it looks like your database usage is 0%

I didn’t ask where your backups are, I suggested you might try to restore them. I assume you do have the backups and if they are on an external drive they should be able to confirmed as still there if you plug the drive into your windows PC.

I would try a reinstall operating system first then see if you can copy over the codecs. Maybe remove the USB to be safe when you do this. Power down the system before you disconnect.

I reinstalled the operating system! How do I opy over he codecs?

Thank you! I have Done exactly this but when I drag the file to the codec folder motvind happens?!

So just to double check: you’ve extracted the tar.xz archive, and only copied ‘ffmpeg’ to the Data network share right? Could you perhaps take a screenshot of the Data network share, so we can see?

I’m not entirely convinced you’ve placed in the correct folder. What exactly does your J: drive point to?

You should put it on your ROCK under Data/Codecs. That’s ‘\\ROCK\Data\Codecs’ in the navigation bar of Windows Explorer. See for more info.

J: is a flashdrive! I only showed so you can see it is the fmpeg only! This I have tried to copy to the Data folder shown but it does not work! Copy/ paste is not possible? Why? How do I place it there?

Gotcha. There’s no need to put it on a flashdrive. As I mentioned earlier, and which is also detailed in the KB article I referenced, you can access your Rock via Windows Explorer. Just type in \\ROCK\Data\Codecs and that should bring up the folder in which to place the ffmpeg file.

In the pictureabove you can see just that! But how do I place the ffmpge file there?

I suggest you check your own screenshots again and then re-read my posts :slight_smile:

Your pictures show (in this order):

  1. Google Chrome with \\rock\data\Codecs in the url bar and
  2. Windows Explorer with J: in the navigation bar

What you didn’t do, and what I suggested you do, is Windows Explorer with \\rock\Data\Codecs. This will allow you to just drag and drop the ffmpeg file into that location.

1 Like

Aha! Thank you for not giving up on me! Now it worked! How do I proceed?