Comatose Nucleus +


In July, 2021, I purchased a Nucleus Plus from Roon. It has worked well since, but just recently it has refused to connect to my network.

Here is what I’ve tried:

  1. I checked the Ethernet connection. Both the green and yellow lights on the Nucleus are illuminated, but I replaced the cable with a new one for good measure

  2. I rebooted the Nucleus several times.

  3. I rebooted my router, and checked that all other devices on my network were connected and running. The static IP address that I was using with Nucleus does not show on my router as connected.

  4. Per the recommendations I’ve seen on the Roon support forum, I tried connecting the Nucleus to a monitor using HDMI. There are two HDMI on the Nucleus, and the manual does not specify which is to be used for video output. So, I tried both. My monitors (I tried with two different units) indicated that there was no signal from the Nucleus.

  5. I swore at the Nucleus a lot, and stamped my feet up and down.

Nothing worked, and the Nucleus still doesn’t work either.

What’s next?

Rick Quisenberry

I am going to tag @support for you @Rick_Quisenberry. They will be back in the office tomorrow and will get back to you about other questions or a possible RMA.

Hi Rick,

First off, I’m sorry you’ve had issues but the quote referenced above admittedly made me giggle.

I’m going to send you a private message with the steps for a warranty repair.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.